GTR Forum banner

41 - 52 of 52 Posts

·
Premium Member
Joined
·
7,635 Posts
I wish. Family stuff this weekend but tomoz it will happen
 

·
Registered
Joined
·
2,730 Posts
Discussion Starter #42
Just done my tsb clips. Nothing wrong at all with my solenoid pistons. Put the clips on anyway. What a nightmare. Nissan allow 1 hour 42 minutes for this job. I took about 7 hours, going carefully :)
Changed the filters for new, and cleaned the magnets. What a mess.
The box is a lot lighter now it’s not carrying all that powdered metal :chuckle:
 

·
Registered
Joined
·
2,730 Posts
Discussion Starter #44
No I didn***8217;t strip the solenoid pack. I***8217;m not entirely sure why it took so long.
I did have to rivet a bit of tin back on the under tray that covers the box.
It was really really hot and sweaty, and I took my time. Cleaning the pan and the magnets too. It all adds up I guess. I still think 1 hour 42 minutes would be a really hap hazard shoddy job though
 

·
Registered
Joined
·
2,730 Posts
Discussion Starter #45
Got a problem guys. :confused:

So after fitting tsb clips, and new filters, and fresh Motul DCTF, my gearbox oil pump now whines a bit more than it did :eek:

Dodson pickup filter, and a Radium mesh line filter (I think stock is paper).
I’m confused as to why and how I’ve managed to make the box louder?
It’s definitely smoother and more positive, but why whining more?
God damn it :mad:
 

·
Premium Member
Joined
·
7,635 Posts
Sorry chaps never got a chance before heading off on holiday. Hopefully a week or so***8217;s time
 

·
Registered
Joined
·
2,730 Posts
Discussion Starter #49
MOT passed again. Nothing to report. That***8217;s 8 in a row. No advisories, nothing.
You still on holidays CC?
 

·
Premium Member
Joined
·
7,635 Posts
Been back a week but just not had any time to do it.
 

·
Premium Member
Joined
·
7,635 Posts
MOT passed again. Nothing to report. That***8217;s 8 in a row. No advisories, nothing.
You still on holidays CC?
Alright kidda...

The one good thing about lock-down is getting crap done that's been put off and put off. I also got an RS4 back in October so havent driven the GTR at all for months.

So today swapped out the TCM ECU, paid for another TCM Ecutek license and had Dan at Litchfield send me an updated TCM ROM (ridiculously good service given the circumstances, massive thanks to Iain and Dan).

Initially things were weird; idle all over the place, car shot a "engine malfunction" warning, DTC codes were Torque Value Error A+B or summat, so reset ECU and everything went back to normal.

All's working well it would appear as of now, driven it back and forth on the drive but haven't been out for a proper drive yet. One interesting change is a whine from the box which I'm sure is the trans pump so maybe later trannies run a higher pressure?

I'll update tomorrow if there's anything to add that would change the above.

BTW this is a MY17 TCM ECU.

Also ProECU doesnt like the mismatch at all. I had to manually select the ECU as the software wouldnt identify any of the car's ECUs at all.
 

·
Registered
Joined
·
2,888 Posts
Just for info if you stick a 2015 on trans in a CBA it will not work unless you use matching TCM OR swap the older valve body !!!! Just so you know.
 
41 - 52 of 52 Posts
Top