GTR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
i have a r32 gtr , in the morning when i first turn on the car the 4wd light comes on ,disabling the 4wd system , im getting a error code of 18 flashes on
the attessa computer ,(pressure switch) harness is ok ,anyone fixed this issue easily ,ie fluid bleed etc ,dont want to replace the hydraulic unit if there is a simple fix
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #2 · (Edited)
k, replaced all the fluid,no change,cleaned contacts to hydraulic terminals,no change,cleaned relay contacts to pump,no change followed diagnostics as per manual, and according to that harness is faulty, wtf does that mean!
 

·
Registered
Joined
·
1,092 Posts
Have you tried cleaning the sensors on the wheels?
Could be nothing to do with it but it is good maintenance anyway.
Any deeper than this i am sorry but i would be lost.
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #4 ·
does anyone know a goos nissan mechanic to email that has in depth knowledge of the attessa circuits and codes?
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #5 ·
when the car is first turned on
in the morning,the 4wd light comes on the dash and disables the 4wd system,
i have used the gtr workshop manual 4 the error code that flashes on the ets
computer and it says pressure switch problem, the switch that is closed when
the pressure for the 4wd system is low, runs the pressure motor till the
pressure opens the switch saying there is enough pressure in the system, now
the problem is after the switch is opened initally it has to remain open for
a certain amount of time to not cause and error if it closes which it does
early on startup it causes this error,so either the switch is faulty closing
too soon,or the system is loosing pressure too early causing the switch to
close again,does anyone there know if the pressure switch is soley
deactivated on pressure alone ,or if it has a sensor of some sort that tells
it to open and close?cheers
 

·
Registered
Joined
·
10 Posts
hey! we have the same problem.. LED flashes 18 - pressure switch, and have not resolved it till now.. at the same time, the the needle indicating the front torque in the dash does not move up upon starting the engine and driving the car. have you observed the same thing? have you resolved your car's problem?
 
1 - 10 of 10 Posts
Top