GTR Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hi, Not sure if this is the right section! But I have a few issues with my R33 GTR that I owned for 3 years now.

When I rev the engine cold it knocks but not when its hot! Runs great with plenty power and its been like this for years now! Any ideas what it could be?

Issue number 2 is that when I compression test it, all 6 cylinders read 100 psi! It's been like this for years too! When I last did a compression test they read 100 psi aswell!
Same gauge both times and its got a Cosworth headgasket fitted. The engine has stock turbos running at 0.9 bar and it makes 380hp at the flywheel with these issues!

Thanks for any help or ideas! :)
 

·
Registered
Joined
·
1,844 Posts
Hi mate, 1st issue, not sure. Someone will give you an answer to that.
2nd issue, good all the pressures are within 10% of each other, but, seems very low to me.
Mine are around 178psi..across the 6 cylinders, but you say she runs ok?

Will be interesting to hear other peoples input.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
Hi mate, 1st issue, not sure. Someone will give you an answer to that.
2nd issue, good all the pressures are within 10% of each other, but, seems very low to me.
Mine are around 178psi..across the 6 cylinders, but you say she runs ok?

Will be interesting to hear other peoples input.
Yeah runs great and makes good power! The engine was rebuilt by Garage D aswell.
 
1 - 3 of 3 Posts
Top