GTR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
Just purchased the r35 and car had different wheels on.. ive bought it with the standard wheels back on which had to have the tpms sensors fitted back to standard wheels..
Since then the car has thrown up an abs light and esp light with traction control light aswell..

It does go off sometimes but then comes back on... any ideas anyone??
 

·
Premium Member
Joined
·
126 Posts
Just purchased the r35 and car had different wheels on.. ive bought it with the standard wheels back on which had to have the tpms sensors fitted back to standard wheels..
Since then the car has thrown up an abs light and esp light with traction control light aswell..

It does go off sometimes but then comes back on... any ideas anyone??


Hi


Do you have a code reader at all mate?

My guess would be abs pump, it will go on and off but in time will stay on permenantly. Its a pretty common problem and one i have had myself

Controlunits.co.uk can repair them at a decent price
 

·
Registered
Joined
·
2,905 Posts
Just purchased the r35 and car had different wheels on.. ive bought it with the standard wheels back on which had to have the tpms sensors fitted back to standard wheels..
Since then the car has thrown up an abs light and esp light with traction control light aswell..

It does go off sometimes but then comes back on... any ideas anyone??
In my experience coming and going is ABS pump on the way out, it needs sending off and mending and we only found one place we are happy using, we have a repaired unit in stock normally but try to keep the original ecu with the car, so mif you change pumps swap the ecu as well
 

·
Registered
Joined
·
1,804 Posts
Had the very same problem a while back, the GTR went in for a service at Litchfields and Neil said worst case it would be the ABS pump, best case it would be a dirty ABS sensor, turned out to be a dirty sensor, they cleaned it up in minutes and cleared the fault.
Happy days!
 

·
Vendor
Joined
·
6,275 Posts
Had the very same problem a while back, the GTR went in for a service at Litchfields and Neil said worst case it would be the ABS pump, best case it would be a dirty ABS sensor, turned out to be a dirty sensor, they cleaned it up in minutes and cleared the fault.
Happy days!
Exactly
 
1 - 8 of 8 Posts
Top