GTR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
892 Posts
Discussion Starter #1
Help my Exhaust rotted and fell to bits as a result it was running like a bag of spanner's low on power etc

Now Fitted new s-steel downpipes, de cat pipe, cat back system

but it still don't feel ( sound Right ) when i rev it it's not smooth anymore not as bad as a missfire but more un-even, lumpy, slight stumble to the sound and feel through loud the peddle

and when i take it out its still low on power

plugs have been changed but the old one's were not that bad

Where do i check next is there any quick fixes

is there any way of checking the air flow meter's and cleaning them ??

or is it just better to hook it upto a diagnostic computer ?
 

·
Registered
Joined
·
2,849 Posts
you have had the whole restrictive exhaust removed and replaced with a much more free flowing system, the car will run differently, i thought the standard ecu could adjust to small mods though as isnt it self learning to a certain degree?

you may have to get a chip to suit the mods
 

·
Registered
Joined
·
3,207 Posts
What ecu does it have?

I'd disconnect the battery (wheels pointing straight of course) leave it over night and then take it out the next day see how it runs and rags the tits off it!

Then go from there.
 

·
Registered
Joined
·
1,316 Posts
Re-set the ecu as mentioned above.

Personally I would let it idle for 5 mins or so or at least until warm, then stick on air con etc and leave for another few mintues then turn a/c off again.

after 10 mins or so go and give it a good blast. The ECU will self learn to a certain extent but keep your eye on boost gauge for spikes now you have removed the resrictions.

Other than that I would go for an aftermarket ECU and a boost contoller to get the extra bhp out of it.

What model Skyline is it? speak to tweenierob or RSP etc...

Kev
 

·
Registered
Joined
·
892 Posts
Discussion Starter #7
my plans are to send it to Mr Tweenierobs sir's establishment for a HKS F Con Pro and Set up as we have Spoken in the past but other commitments have taken the funds that were on the way to his pocket ( Sorry Mr Rob Sir ) but just looking at finding out what things i could check to see why it feels low on power and not as smooth as it did.......looking into checks on the coilpacks, afm's, plug gaps....................
 

·
Registered
Joined
·
1,316 Posts
My fuel filter caused me a similar problem and an easy one to change,

May be worth a treating to a filter and some plugs gapped correctly and give the AFMs a good clean. I also had a lambda problem that used to cause over fueling at low revs. What is your fuel consumption like? Has it gone down as well. I was losing 30 - 40 miles per tank with the Lambda issue.

It can get costly keep checking and buying different parts to test! be better off getting it off to Tweenie for a good check over.

Kev
 

·
Registered
Joined
·
892 Posts
Discussion Starter #10
ok thank's goghat going to check the easy stuff .........send me a pm with your contact details if you dont mind....
 

·
Registered
Joined
·
892 Posts
Discussion Starter #11
just a quick update .....

took the plugs & Coilpacks out to check gaps etc and found number 4 plug wet with petrol while all the rest were dry
re-gaped all & dry'd and cleaned the number 4 plug feels better
but going to check number 4 again to see if stay's dry
 
1 - 11 of 11 Posts
Top