GTR Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
Hello, my car is running very very rich. It has a 200cpi catalyzer and the emission test reads 3% co in idle! should be anywhere between 0.0 and 0.5%
i've been told it has 600cc nismo injectors, but if i look the pictures of other injectors mine should be 550cc

here pic of mine:


pic of rhd japan 550cc nismo:



pic of rhd japan 600cc nismo:



okay then here the adjustment on my power fc:


if i'm right with the 550cc injectors, the settings should be
80% +0.1msec

can this be the solution? actually i have not measured the fuel pressure..another option..
 

·
Registered
Joined
·
1,327 Posts
Measure Fuelpressure and get the Injectors flow checked :) Abbey and TR do flow checks.

Btw. if the Swiss Exhaust Gas check is like the German, forget about passing it with a "good" map :)

Marc
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #4 ·
Hello Stachi,

i have to buy a fuel pressure gauge :D
The Standart emission Test, which you have to do here every 2 years is really simple..warm up the engine then measure in idle. depends on manufacturer, but normally cat vehicles should have 0-0.5 co, <100ppm hc and >12% CO2
For the homologation it's another story..as my car is first registrated before dec.95 i must only get euro1 test on the emission-dyno. but first i have to find out why it's running so rich.
 

·
Registered
Joined
·
1,327 Posts
I've got a homologated R33 GTR myself :p
Have you checked with a wide band lambda already? I'd get those injectors flowchecked...

Stabbing in the Dark isn't something you want to do with your engine. It's easily spoiled, so why risk it :)

Marc
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #7 ·
with euro 1 or euro 2?
actually i have no wideband here, i will get one, but i do not need one to see that's running way too rich :D if i change the settings it make sense. perhaps someone here has the same injectors and the right settings ;)
sending the injectors from switzerland to uk and get it back here is not economical, then i better buy some new ones xD
 

·
Registered
Joined
·
1,327 Posts
There are quite some Shops that do it in Germany too, I don't know about Switzerland.
My personal car has got Euro1, but that's just because I don't care about the tax that much.

Are you running the PowerFC with O2 Feedback on or off? Could be worth a try. And check out the Lambda Sensor Voltage, maybe one is dead too..

Marc
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #9 ·
after i don't drove the car for 3 months and the battery was empty, i drove it now a little bit and checked all settings again. now i checked again the emissions and it reads 0.99%co an 338 hc, engine only warmed up, not driven an that with a 200cpi race cat ^^
now i replace it with the oem one and check again. looks good now :D
 

·
Registered
Joined
·
793 Posts
it means someone hasn't set your injectors properly.

100% means stock 444cc injectors

550s should be set at 80% but I wouldn't go ahead and change it as it may have been mapped like this and doing so will result in leaner fuel ratio across the entire map. I would get it looked at by a tuner first as it may need a map.
 

·
Registered
Joined
·
495 Posts
It does change idle speeds so it can't be locked but off I turn idle up then turn it off then its back to where it was.ive read that it needs a direct power source or something and its in a silvia not a skyline so this might be the problem,its booked in for Friday
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top