GTR Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
The car has gone back to the garage where I bought it to be looked at :(

They think it's the AFM - tickover occasionally rises to 1500 rpm, and occasionally just stops

Oil pressure also seems to be up and down a lot, but having read through so many posts on here, that's not unusual for a stock sender. I hope that's all it is :eek:

The guy at the garage has been very good about it so far, so here's hoping.




Graham
 

·
Registered
Joined
·
234 Posts
tell him to check the pcv valve in the manifold, or the TPS has been moved...
 

·
Registered
Joined
·
180 Posts
Discussion Starter #6
Got the car back today, great birthday present :D

They changed the AFM, Idle Control Valve & TPS.

Thought it was ok at first, but Idle is now about 1800 rpm once warm :eek:. But if I switchoff an restart the motor, it is about 1000 rpm :confused:

I'm taking it to Weston Performabnce tomorrow to go on the Dyno, I hope they can sort it out.

Drives great otherwise.

Graham
 

·
Administrator
Joined
·
31,759 Posts
get em to check inlet manifold gasgets

they can casue erratic idling

mook
 

·
Registered
Joined
·
180 Posts
Discussion Starter #8
Thanks Mook, I will.

I'll let you know how it goes.

Graham
 

·
Registered
Joined
·
180 Posts
Discussion Starter #11
So the car went on the Dyno at Weston on Friday pm. It turned out that the TPS was not quite set correctly, Ignition was not quite right and the Idle Valve was set too high. It was also running slightly rich on boost.

Anyway, saw 206bhp - just about right for this engine, and it never missed a beat, right up to red line in 3rd (Auto box) and 109mph :eek:

And here's me treating it with kid gloves while I was unsure about the problems.

Can I say a big thank you to Paul and Debbie Weston for looking after me on the day, and Greg for putting the car through the tests even though he should have been moving house!

Graham
 

·
Registered
Joined
·
180 Posts
Discussion Starter #12
This is not the end of the story though.

Went to Santa Pod yesterday for the Flame & Thunder show, and the engine started to hesitate on the way home (not under load).

Then I stopped at an island, and when I pulled away it kangaroo'd for about 5 seconds, then ok.

Saw a couple of minor hesitations later on, following a short burst of boost.

Today it cut out completely as I was just accelerating out of a turn. Started again no problem. Weird, it feels like fuel starvation, but very infrequent, and when I push hard, it goes like it the proverbial scalded cat. (Remember I am an ex Volvo owner)

I'm thinking drain the fuel, change filter etc. Any other ideas?

Thanks for your input guys.

Graham
 
1 - 12 of 12 Posts
Top