GTR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
I'm not sure if a solution was found to solve it. It's a GTR idiosyncrasy just forget it and drive ! If no shaft play, it's pretty normal.
 

·
Registered
Joined
·
924 Posts
It's a Litcho replacement mate
Oh no!!

That's really not good news for all of us.

I was hoping this was the Holy Grail when it came to bell housing fixes.

Please keep us posted as to what Litchfields have to say. I'm sure they'll replace is with their reputation but a real worry that it's failed.

Satan
 

·
Registered
Joined
·
2,619 Posts
I've been told all will be sorted mate, waiting until next service as want circlips done at same time. No noise from it at present but there is play. I'll keep you posted ; )
 

·
Registered
Joined
·
924 Posts
I've been told all will be sorted mate, waiting until next service as want circlips done at same time. No noise from it at present but there is play. I'll keep you posted ; )
I've no doubt Litchfields will sort it, they are a good outfit, but what worries me is that I hope this is an isolated failure, not an issue with their design.

I'm on the original at 23K miles and no issue yet but I'm sure it will happen eventually and I want a permanent fix when it does.

How many miles had you done on this one?

Satan
 

·
Registered
Joined
·
924 Posts
Less than 3k mate : (
Oh no. That's a bummer. Let's hope it's just a 1 off failure and I'm sure you'll get good service from Iain but I'd like to know what has gone wrong on the new design.

Keep us all posted mate and good luck. As said I'm sure one day I'll need a fix but for now all is still good.

Satan.
 

·
Registered
Joined
·
924 Posts
Saucy

How did you get with the Bell housing replacement? What was the course of the failure? Was it a one-off or problem with the design?

Regards Satan
 
1 - 11 of 11 Posts
Top