GTR Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
Hi All,

Took my R32 out to a local JDM meet yesterday, and decided to stretch her legs on the run out there...

I was gunning it hard in 2nd on hi boost setting (1.3 bar) and hit what felt like boost cut (momentary cut out of the engine/loss of power and then back to normal again), except that, upon checking my peak levels on my Defis, boost had only spiked at 1.4 bar (warning level is set to 1.6 - I'm not actually sure what level boost cut is set to).

So, to double-check, I turned down to lo boost (1 bar) and had a play again... Same thing happened. I tried it a couple of times more, and noted that each time it happened, it was at 7k rpm. I guess it can't be boost cut, as it wasn't reaching anywhere near the warning level when set to lo boost? Could it be a rev limiter of some sort? It's running a Link G4. Ron (Nightcrawler) has advised me not to rev it over 7.5k, which I wouldn't anyway, but just wanted to check it out.

Thanks in advance!
 

·
Registered
Joined
·
1,313 Posts
not really sure what happened to it. didn't have this issue at all as I never pushed the engine that hard. look at the dyno print out (the last one from MGT), cant remember if it reached 7000rpm. garth (MGT) did not mention anything about limiting the rev on his map but try ringing him if he set a rev limit. im sure he will help you out :thumbsup:
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #4 ·
Hmm yeah that could make sense! Will give MGT a buzz tomorrow. Either way, will be changing at 6k from now on haha!
 
1 - 5 of 5 Posts
Top