GTR Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
I know something broke and I have my guess but I'm going to put this out here and see what you guys think. This shouldn't have happened but I guess stuff is going to break and especially when the power is increased but this is an odd one.

My Transmission is a route 6 cross with 2 & 3 gears changed, I'm running Red line heavy duty shock proof gear oil, street tires 255 X17, outside temperature around 50, my operating temperature 68 Celsius mine usually runs at that temp, boosted 1.44, and I was on an on ramp entering a highway.

How it happened: Entering ramp to do a test run 1st gear shifted at 7898 rpm into 2nd, full throttle till 7352 rpm and noise and obvious drive issues. Noise is there when clutch is out alls quiet when clutch is pressed. Let clutch out noise and doesn’t seem to engage and then jerk it engages for an instant. Couldn’t drive had to be towed home.

I thought it was something with my clutch nope clutch is fine put tranny in gear turn output shaft and definite catching going on inside. I think I know what it is but I want to hear what other people have to say before I say anything.

Noise is clang clang clang clang sounds to be in sequence with rotation of flywheel.

I always data log thats how I know exactly when it happened
 

·
Registered
Joined
·
150 Posts
hmmm, is it driveable? as in are there any specific gears that dont work?
i blew third gear about 6 months ago, all gears worked except for third, but noises were similar to what you are saying... i suppose you cant know for sure unless you drop the gearbox...
 
1 - 2 of 2 Posts
Top