GTR Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
my car (59 reg) has just gone into limp mode, with both the engine and trans malfuntion warnings coming up. the engine light stays on and the trans light flashes :eek: i was pulling out of a junction in 1st and shifting to 2nd in manual when it happened. the car selects 1,3,5 and reverse, but only in auto mode.

i've used the throttle pedal method to get a code and all i get is 0000. i've tried to clear the error by holding down the throttle whilst the engine lights flashing, is that right.?

the nearest hpc is manchester which is one and a half hours away.!

any clues or is it time to start bending over.. :nervous:
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
unfortunately not mate, im the only one dumb enough to buy this kind of car out of us all. i'll have to see if i can get it read locally or buy a cable from one of the tuners, just seems odd that all i get is error 0000.?
 

·
Registered
Joined
·
470 Posts
Must be someone near you who has an obd2 code reader
Just plug it in to the diagnostic socket and read the error codes then erase codes
Hopefully it won't come back up again but if it does then you have a prob somewhere

You can pick them up new off eBay for a score, bloody handy to carry one with you as they will take car out of limp mode and get you to where your going but if fault recurs then let someone look at it who knows what there doing
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
a readers one of those things i keep meaning to buy, but never have, good excuse to now though.! a mate works as a mechanic for a local garage so i'll see if theirs will read it on monday. heres hoping.. :runaway:
 

·
Registered
Joined
·
1,423 Posts
a readers one of those things i keep meaning to buy, but never have, good excuse to now though.! a mate works as a mechanic for a local garage so i'll see if theirs will read it on monday. heres hoping.. :runaway:
Hope its a simple fix mate
good luck


Goldie
 

·
Registered
Joined
·
2,487 Posts
Whereabouts are you in the Northwest? I'm based just north of Liverpool, and am often on Wirral. I might be able to help you out, I have an Ecutek cable.
 

·
Premium Member
Joined
·
5,786 Posts
the odd gear selection sounds like the selector forks have swarf build up and could do with a clean. As others have said you need to get the code read and then do a search of what it means. A benefit of having cobb is that if I ever get a code thrown up I can immediately read the fault, see what it is and then if appropriate clear it.
 

·
Registered
Joined
·
85 Posts
my car (59 reg) has just gone into limp mode, with both the engine and trans malfuntion warnings coming up. the engine light stays on and the trans light flashes :eek: i was pulling out of a junction in 1st and shifting to 2nd in manual when it happened. the car selects 1,3,5 and reverse, but only in auto mode.

i've used the throttle pedal method to get a code and all i get is 0000. i've tried to clear the error by holding down the throttle whilst the engine lights flashing, is that right.?

the nearest hpc is manchester which is one and a half hours away.!

any clues or is it time to start bending over.. :nervous:
could be basket or seal
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
cheers for the replies guys, hopefully i can get some codes out of it next week and see what happens from there.
 

·
Registered
Joined
·
470 Posts
The obd2 will read the fault codes and clear them no problem

That's all you really need, the ecutek cable does a lot more but you don't need that to just read and erase codes

As said hopefully it's something simple like a solenoid problem that may have sorted itself out
 

·
Registered
Joined
·
2,619 Posts
Hopefully just a solenoid clean mate.

On the note of a reader, I bought one after a recommendation on here. Works via wifi with a app on your phone, think I have dash command app. Only a score for the reader :)
 

·
Vendor
Joined
·
480 Posts
Either sticky shift fork (gearstops/fork issue) or blown a clutch seal... If the former, good chance you can clear out the codes and carry on. This is an issue quite a few guys have, it can be intermittant. We're working on a fix for at the mo, becoming very common.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #15 ·
Hopefully that's it, I'll know by Tuesday what the codes are as I've ordered an obd2 so i'll try to clear them, then see what happens.. it's like owning a cossie all over again... :rolleyes:
 

·
Registered
Joined
·
924 Posts
my car (59 reg) has just gone into limp mode, with both the engine and trans malfuntion warnings coming up. the engine light stays on and the trans light flashes :eek: i was pulling out of a junction in 1st and shifting to 2nd in manual when it happened. the car selects 1,3,5 and reverse, but only in auto mode.

i've used the throttle pedal method to get a code and all i get is 0000. i've tried to clear the error by holding down the throttle whilst the engine lights flashing, is that right.?

the nearest hpc is manchester which is one and a half hours away.!

any clues or is it time to start bending over.. :nervous:
Jonny G has offered you his cable to help but see you didn't reply to him.

I'm also in North Wales but haven't got the Ecuteck cable or I would swing by. Where are you based?

Satan
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #17 ·
sorry for the delay in answering the questions i've been 300 miles away from the car since sunday due to a family emergency (all ok now), and thanks for the offers of help.

i'm in the llandudno area for those enquiring, and i've bought a obd2 reader and the torque app.

the error i found was p2837 - Shift Fork "B" Position Circuit Range/Performance. i've cleared it and driven the car today about 30 miles in manual and auto and all seems fine. the error happened at the end of a rather 'spirited' drive around snowdonia in race mode, so maybe something got a little warm.

thanks again for the advice, guess its time to start driving like miss daisy again..!
 
1 - 20 of 24 Posts
Top