GTR Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
613 Posts
Discussion Starter · #1 ·
just got my gtr back from garage after fitting rebuilt steel turbos and a new gearbox.

the coolant system was all redone as was oil etc.

the problem is wen i check my radiator in morning wen cold it seems a little low, water is just sat were the fins are (i thought it should be up the neck of rad??)
and a couple of times i have put about a cup full of water just top it up. but everytime i check it, it always seems to be a bit on the low side

i have checked for leaks on all pipes etc
car is not overheating
no mixture with oil

does any one know were this cup full of water is going??
could it be my rad cap or is it serious?
cheers ant
 
Joined
·
3,666 Posts
Have you checked the water in the expansion tank, water expands when it gets hot so the water is pushed out of the radiator neck into the expansion tank , when it cools down it should suck the water back into the radiator.

So best check the level is correct in the expansion tank , and make sure your rad cap is working all okay , and the most important make sure your cooling system is bleed correctly.
 

·
Registered
Joined
·
613 Posts
Discussion Starter · #8 ·
Have you checked the water in the expansion tank, water expands when it gets hot so the water is pushed out of the radiator neck into the expansion tank , when it cools down it should suck the water back into the radiator.

So best check the level is correct in the expansion tank , and make sure your rad cap is working all okay , and the most important make sure your cooling system is bleed correctly.

thanks, will do the necessary checks asap.
 

·
Registered
Joined
·
613 Posts
Discussion Starter · #10 ·
done some checks, pressure tests, looked for leaks etc etc
and noticed that there was no pressure in the water pipes when hot,

so i have changed the rad cap and there was pressure almost straight away!!

hopefully this has cured it !! thank fcuk!!

i will let u guys know 2morrow if the water has dropped like it has been doin or not dropped like it should.

thanks for the help
ant
 

·
Registered
Joined
·
613 Posts
Discussion Starter · #11 ·
right this is really ****@ng me off now!!

been out in the car most of the day then left it to cool down and checked water rad empty again!!

were the fcuk is my water going!!!

1. there is no mix with the oil
2. there is no steam from exhaust
3. looked all around for leaks on pipes and turbos etc
4. fitted a new rad cap
5. bled the system dont know how many times
6. the car runs fine with performance and no loss of it
7. and it never over heats!!!

please i ask again were the fcuk is my water going:(
 

·
Registered
Joined
·
2,359 Posts
Small leak from one of the hoses under the inlet manifold? some only leak after you have stopped and the under bonnet temp has risen
 

·
Registered
Joined
·
6,051 Posts
Problem sometimes is they get a tiny leak that just steams when hot then stops pretty much as soon as the engine is switched off, the area stays dry too and the steam quickly evapourates, Had this on my 300, took ages to find it. it turned out to be a very tiny split in a pipe.
 

·
Registered
Joined
·
934 Posts
With a hot or cold engine? As its already been said, sometimes the leak will only be there when hot.

We would be more than happy to have a look somtime if needed. The last think you want to be doing is changing a headgasket if its not needed!

Richard
 

·
Registered
Joined
·
613 Posts
Discussion Starter · #19 ·
With a hot or cold engine? As its already been said, sometimes the leak will only be there when hot.

We would be more than happy to have a look somtime if needed. The last think you want to be doing is changing a headgasket if its not needed!

Richard
would really apprecite that, when?
 
1 - 20 of 22 Posts
Top