GTR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
404 Posts
Discussion Starter #1
Hi Peeps

I've made one of those blatz / consult cables and loaded up ECUtalk to try and get to the bottom of a few problems that have recently developed on my R32
GTR.

Anyway I've observed a few things that trouble me. Firstly my MAF sensors do not read the same values. One is reads higher than the other. Is this normal? Secondly when accelerating then closing throttle, one MAF goes almost to 0.4V. The other stays fairly high. Any ideas? I've attached a picture. Yellow is sensor1, pink is sensor2, blue is throttle position sensor.

Secondly, after driving the car, leaving is a few hours then coming back and taking it out again, the timing retards to 10BTDC !!! This cause stuttering which after a 5 mins of driving clears. You can see a definite change in the second graph.. Very odd!!!.. any ideas??

Cheers
 

Attachments

·
Registered
Joined
·
106 Posts
Hi Peeps

I've made one of those blatz / consult cables and loaded up ECUtalk to try and get to the bottom of a few problems that have recently developed on my R32
GTR.

Anyway I've observed a few things that trouble me. Firstly my MAF sensors do not read the same values. One is reads higher than the other. Is this normal? Secondly when accelerating then closing throttle, one MAF goes almost to 0.4V. The other stays fairly high. Any ideas? I've attached a picture. Yellow is sensor1, pink is sensor2, blue is throttle position sensor.

Secondly, after driving the car, leaving is a few hours then coming back and taking it out again, the timing retards to 10BTDC !!! This cause stuttering which after a 5 mins of driving clears. You can see a definite change in the second graph.. Very odd!!!.. any ideas??

Cheers
Sounds like your MAFS need re-soldering and cleaning.
 

·
Registered
Joined
·
404 Posts
Discussion Starter #4
MartinC, I've sent an email with my best explanations of the issues. The MAFs do seem to stay withing 0.4V of each other unless I take throttle off. Then the difference varies massively. One will typically drop to 1V and the other will stay high, they then return slowly to a nominal 0.1V difference between each other. I suspect this is air flowing out of the pressured system back over the MAFs, but one turbo will be spinning quicker than the other??
 
1 - 5 of 5 Posts
Top