GTR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
I've noticed that my driver's side DRL is sometimes not working.
Has anyone else had this issue?
Seems like I have a loose wire, connection or something.
Does anyone know how you get to it?
Appreciate any help..
 

·
Vendor
Joined
·
2,031 Posts
You might be as well just removing the front bumper as the undertray bolts just tend to be seized and end up damaging the bumper Trying to loosen them off.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #5
Thanks for the replies. Cars in at Litchfields soon with Binnacle Cluster illumination issues. So they can have a look then.
Must just be a coincidence, but since I've poly bushed everywhere I'm getting all these issues...lol...
Shaking everything loose...lol..
 

·
Vendor
Joined
·
2,031 Posts
I’ve never been in any car that’s been polybushed that’s drives half comfortable, I think oem is generally the sweet spot.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #7
I’ve never been in any car that’s been polybushed that’s drives half comfortable, I think oem is generally the sweet spot.
I wasn't sure at first, but I'm used to it now. One thing I've struggled with is the bloody Michelin tyres PS4, the cars just too heavy and bounces around. This has much improved that. But yes at a cost... With R888R on its a different car again...
 

·
Registered
Joined
·
196 Posts
Discussion Starter #9
265/305 Michelin and 285/315 R888R.
 
1 - 9 of 9 Posts
Top