GTR Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
OK so my r32 was on the dyno today and the fuel pressure keeps dropping off now.

Its got a brand new deatschwerks dw300 fuel pump with new filters fitted and the hard wire job done running constant 14.1v now but it won't hold pressure in the higher revs.

Its running standard fuel rail with denso 700cc injectors and a nismo fpr.
My mapper seems to think the pump is faulty and wants me to swap it now for a walbro pump instead.

Can anybody point me in the right direction to solving what is dropping the pressure is it a faulty fuel pump or something else?
 

·
Skyline Section Manager
Joined
·
11,878 Posts
Are you reading pressure before or after the imjectors?
 

·
Skyline Section Manager
Joined
·
11,878 Posts
Are your fuel line big enough to deliver that much fuel?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #8
Well its a 340lph pump so it should have loads of head room for my application.
Not running big power about 400-500hp
 

·
Skyline Section Manager
Joined
·
11,878 Posts
Well its a 340lph pump so it should have loads of head room for my application.
Not running big power about 400-500hp
Where are you reading the pressure from?
 

·
Registered
Joined
·
101 Posts
Discussion Starter #10
Well id imagine the garage has it between fuel filter and fuel rail.

The garage is going to change the deatschwerks pump for a walbro tomorrow to confirm the pump is at fault.
 

·
Registered
Joined
·
344 Posts
340lph should be plenty for that power, the question is what boost level are you hitting, and does that pump flow enough fuel at the level ie 45psi + boost psi

Fuel pressure gauge should be at the regulator or between regulator and fuel rail
 

·
Registered
Joined
·
88 Posts
I had the same problem with the Aeromotive pump, which looks identical to the Deatschwerks. I switched to the latter and the problem was solved. I can't be sure but I think the Aeromotive might not have been genuine, the company I bought it from has vanished from the face of the earth anyway. Where did you get the pump?

One thing is for sure, the spec of the pump is enough for the power you are trying to achieve.
 

·
Registered
Joined
·
3,583 Posts
I ran 450 hp in my r32 on a stock fuel pump with no pressure drop issues.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #16
Where did you buy it? We offer 3 years warranty on the pump.

Contact your supplier for a replacement.
Well this might be awkward but you supplied it to me. Haha!

I've only ever heard good things about these pumps.
Swapping for a walbro tomorrow will determine if the deatschwerks pump is in fact faulty or not.

I'll be in contact then for a possible replacement.

Thanks
 

·
Registered
Joined
·
28 Posts
I just had exactly the same thing happen to me. Changed it for a Wolbro 400 and flow is now fine.

Got to get my new deastchwerks 800cc injectors flow tested as well now though. Seems they can't even flow enough fuel to get off idle with no load on engine.

All in all DW is going on my list of stuff not to touch with a barge pole.
 

·
Registered
Joined
·
174 Posts
i have bought a set of 800cc injector..... 1 of them broke at 2500 rpm on dyno.....you can use now like a flute, is always open.......... a lot of fuel inside cilinder...............
 
1 - 20 of 20 Posts
Top