GTR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter · #1 ·
All my wires are one big mess where the control unit kept dropping some of the wires snapped I temporary soldered some wires but not happy at all my oil pressure gauge keeps bouncing and I know there's nothing wrong with my oil pressure got it all plugged into a computer to make sure and my exhaust gauge 90% of the time don't work and also my water temp keeps showing 50+ of whatever the real temp is. Can anyone help or point me to the right direction who specialises in these kind of things. I'm in sidcup Kent

Thanks in advance

Lev
 

·
Registered
Joined
·
228 Posts
hey bud

90% of faults i see with defi gauges is the connections, whether its the plugs that are knackered or the terminals and wires etc most can be traced back to this, i wrote a quick guide on what happens and how to fix it here:

Restomod Compulsion

due to the age of them and the fact the are complete arse to unplug from the gauge and control box the wire tends to pull out of the terminals and boom, problems.

the rest of the hardware seems to be fairly reliable, bar a few leds going kaput and the occasional wire becoming unnattached from the sensor.
 

·
Registered
Joined
·
104 Posts
Discussion Starter · #3 ·
hey bud

90% of faults i see with defi gauges is the connections, whether its the plugs that are knackered or the terminals and wires etc most can be traced back to this, i wrote a quick guide on what happens and how to fix it here:

Restomod Compulsion

due to the age of them and the fact the are complete arse to unplug from the gauge and control box the wire tends to pull out of the terminals and boom, problems.

the rest of the hardware seems to be fairly reliable, bar a few leds going kaput and the occasional wire becoming unnattached from the sensor.
Much appreciated will look Into it. Ideally wanted to know someone to do it as I ant good at DIY lol
 
1 - 4 of 4 Posts
Top