GTR Forum banner
1 - 20 of 26 Posts

·
Banned
Joined
·
174 Posts
Discussion Starter · #1 ·
Hi guys, so it goes like this, i work in a dusty enviroment, theres alot of cars including two GT-S's which you'll all hear about sooner or later, now one of them had its MAF sensor missing and the intercooler i.e. not there. now when i first used to fire it up it would idle fine without these bits. NOW after fitting an intercooler and MAF sensor she doont wanna know about anything above 2500 to 2750 rpms. can you tech gurus chime in? TIA
 

·
GTROC NOBODY
Joined
·
5,981 Posts
Bad idling is normally down to a faulty BOV. If its only revving to mid 2500 range, then sounds like the ECU is in limp mode. Maybe the replacement MAF(AFM) is faulty, sending it into limp mode.
Try draining the ECU by disconnecting the battery and depressing the brake pedal for a while. Reconnect and see if it is any better, if not, try another MAF

Hope that helps
 

·
Banned
Joined
·
174 Posts
Discussion Starter · #3 ·
Thanks for the input, i will try that as soon as im back to the garage. if no joy with what you mentioned, do you reckon it could just be dust in the charge piping?
 

·
GTROC NOBODY
Joined
·
5,981 Posts
Thanks for the input, i will try that as soon as im back to the garage. if no joy with what you mentioned, do you reckon it could just be dust in the charge piping?

Mmm, i doubt it. I'm no expert, but i'd go for the faulty AFM as the culprit. Possibly dust and crap in the BOV. Sometimes the spring does not return properly, thus causing unsteady revs, normally stalling at low revs, but the rev limit you described is typical of an ECU in limp mode...trust me i know:runaway:
 

·
Banned
Joined
·
174 Posts
Discussion Starter · #5 ·
Fair enuff!!! btw when you say BOV, you mean the one that sits just befor the throttle body right. cause when i try to rev i can hear her spool up loudly and the WHPOOSH from the valve!!
 

·
GTROC NOBODY
Joined
·
5,981 Posts
Fair enuff!!! btw when you say BOV, you mean the one that sits just befor the throttle body right. cause when i try to rev i can hear her spool up loudly and the WHPOOSH from the valve!!
Yep thats it. Factory fitted ones i believe at Mitzi ones. Its normally crappy aftermarket ones that leak, but still worth checking. They do naturally get dirtied by the air as it passes by. Normally a just a dirty deposit from the air. TB's can also get a bit sticky sometimes too.
 

·
Banned
Joined
·
174 Posts
Discussion Starter · #7 ·
My freind has a Blitz replacement item for his factory mounting, but...for some reason its not as loud as mine!!
 

·
GTROC NOBODY
Joined
·
5,981 Posts
BTW, how come you reply so fast?! I never see your green light on! You a ninja?
You obviously underestimate my sneakyness.....lol:chuckle:
Sorry, love the Mr Deeds film if you've ever seen it.
Ninja...like it:runaway:
 

·
GTROC NOBODY
Joined
·
5,981 Posts
Nothing.
I'm in stealth mode:smokin:
Its in the user CP control panel. It shows when you are online, or if you choose not to be seen:)
 

·
GTROC NOBODY
Joined
·
5,981 Posts
Indeed my "R" is in stealth mode. So stealthy, i re-badged it as a GTST:chuckle:
Only stage 1 i'm afraid. Nothing special, just very loud:cool:
 

·
Banned
Joined
·
174 Posts
Discussion Starter · #18 ·
LOL, i realised that it is in fact a GT-S!!! had a look at you profile and thought to my self "flushed side repeaters AND a slim body!?" I feel ashamed i could mistake them considering my name!!
 

·
GTROC NOBODY
Joined
·
5,981 Posts
I did have a GTR style bumper on it when i bought it, but i fancied a change but never got round to the sides.
 
1 - 20 of 26 Posts
Top