GTR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi My names Joe,
I'am very new to this site and have not yet introduced myself properly. I recently bought a 96 r33 gts, I've been saving for ages and I'am very pleased. However today I booked it in for MOT and among the usual worn pads ect it failed on emissions. It took the emissions test twice firstly failing on both HC and CO and the second time just CO the results were 0.667 for CO on the first fast idle and 0.490 on the second.
I was told by the previous owner that it failed on emissions when he had it MOT'd aswell the results for that were CO 0.688 and on the second fast idle 0.650 on CO it also failed on the lambda ( 1.050 and 1.033).
I rang up the previous owner today and he said that he had the emissions restored to the factory values for £35 can anyone shed some more light on this. I have also been told that by disconnecting and reconnecting the battery you can restore the emissions to factory values. Other people have told me to just give the engine a good clean and run as it hasn't been run for a while. Finally I have been told it might have something to do with lambda as it has never been replaced
If anyone can give me any more information on these suggestions or perhaps offer suggestions of their own I would be very grateful.
Thanks very much Joe.
 

·
Registered
Joined
·
826 Posts
The Lambda Sensor controls emissions so it could well be that Joe, Disconnecting the battery resets the ecu but i cant see how that would effect emissions (someone else might know how that works).
Have you got the cats fitted..?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
right cheers for speedy response :thumbsup: Its got a completely stock exhaust tbh I'm a newbie to all this but I know its a stock exhaust. It appears that other people on this site have had similiar issues with the lambda sensors. Thanks again and more responses welcome.
 

·
Registered
Joined
·
732 Posts
I had an MOT failure on CO emissions, had a mate of mine off the SX owners club come over and check my lambda sensor out....guess what? Dead sensor...If you know anyone good with a multimeter and cars, get him to check the lambda. This should confirm whether or not its knackered
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Thanks very much everyone for your help I have decided to replace the sensors would anyone be able to tell me where to purchase them as my friend whom I'am modding the car with has been in touch with his supplier and the can find nothing on the parts database??? Thanks again and when I'am off work I will introduce myself properly with pics ect.
 
1 - 6 of 6 Posts
Top