GTR Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
728 Posts
Discussion Starter · #1 ·
After fitting a boost controller and a de-cat pipe to my GTST, the car runs well and goes slightly quicker and better response, however I have noticed a slight problem, it doesn't happen very often but I have experienced 3 times in 3 weeks. The popping noise from the exhaust isn't as loud as firework, but enough for me to know..... I haven't got mad with the boost but only upto 0.8 bar which I think the std ECU will provide enough fuelling for it..

Problem only occured around 5000rpm full load, it lasts about 1 second or 2.... Any expertise advice is appreciated.

Thanks

~Joe~
 

·
Registered
Joined
·
1,239 Posts
hi

could be hitting boost cut but shoudlnt be as are ok up to 0.9 bar
talk to lads on skylinesdownunder asa lot of them are gtsts
they may be able to help
 

·
Registered
Joined
·
728 Posts
Discussion Starter · #3 ·
this is the point I am not 100% sure. I think i have raised this before... The boost level on the controller is measured from MAP sensor on the inlet manifold, surely if it is reading 0.8 bar at that point, it must be higher in the turbo???????? Correct me if I am wrong.... and if the boost cut is around 0.9 bar, then where would that be measuring from????

Thanks..
 

·
Registered
Joined
·
7,272 Posts
Joe,

You need to change your plugs mate. Fit some Greddy Iridium Racing 8's.

The cam timing changes around the 4500-5000rpm mark, and this point is often seen to be the source of a little miss on the RB25DET, especially when the boost is raised and the plugs are a little tired. Probably just a nasty little bit on the stock map.
 
1 - 5 of 5 Posts
Top