GTR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
I have a BNR32 and I'm beginning to run into some problems.

When I accelerate normally the car has no problems until I hit the 4.5k rpm range and the engine starts to sputter and feel like the power is cutting off. If I stomp on the pedal and accelerate hard the car starts to cut off bad at around 4k rpm and continues until around 6k rpm. The car has no idling problems and it runs fine other than that. :runaway:

The highest octane I can run 97UK, could this be an issue? I also thought it might be the MAFs but with the car having no idling problems I wasn't sure. Anyone have any input?
 

·
Registered
Joined
·
111 Posts
Discussion Starter #4
I apologize my knowledge of this engine and set up isn't too great. Its a stock GT-R with a catback and test pipe. Other than that, it's an all stock set up.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #5
Okay great I'll also check out the coil packs as well. Thank you.
 

·
Skyline Section Manager
Joined
·
11,878 Posts
It sounds like you have tracking around your coils under load.
Remove your coils, remove the rubber boot. Clean everything and re-assemble with silicone grease. It's also worth ensuring the ignition pack earth is good. These are both things I have tried and seen work for misfires.
 

·
Registered
Joined
·
111 Posts
Discussion Starter #8
Combat I feel like you're 100% correct after looking more into the problem thank you for the help!
 

·
Registered
Joined
·
111 Posts
Discussion Starter #9
I may just order new plugs anyway, who knows how long they've been in the car lol
 
1 - 9 of 9 Posts
Top