GTR Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
32 Posts
Discussion Starter #1
Hi All,

Just did a airfield day and had a bit of a weird issue. Going through the gears the car pulls hard until it hits around 155mph in 5th when it just stops accelerating (occasionally the revs also drop off like I've taken the foot off the pedal). If I back off the throttle briefly (1 sec) it then pulls hard again all way until I run out of road. Happened every time. The car wasn't overheating and the temps were all normal. It's a Stage 4.25 btw and cobb tuned although I'm probably moving away from this. I'm going to book it into Litchfields to see what they think.
I'm thinking overfueling maybe and a remapping needed? Any other ideas?
 

·
Premium Member
Joined
·
7,635 Posts
If you'd logged your runs you'd most likely have seen teh ECU retarding timing due to knock.

At those high engine loads the most likely reason is high IATs.

I had the very same experience at last year's event and with Litcho's Race intercooler. I logged each run and Iain checked over the logs and they showed retarded ign timing in 5th and 6th due to knock.

Mine is a built engine so nothing to worry about nbut on a standard engine I'd be wary.
 

·
Premium Member
Joined
·
32 Posts
Discussion Starter #3
If you'd logged your runs you'd most likely have seen teh ECU retarding timing due to knock.

At those high engine loads the most likely reason is high IATs.

I had the very same experience at last year's event and with Litcho's Race intercooler. I logged each run and Iain checked over the logs and they showed retarded ign timing in 5th and 6th due to knock.

Mine is a built engine so nothing to worry about nbut on a standard engine I'd be wary.
Cheers for that. I'll get it over the Litchfields before I look at doing any more high speed runs! :)
 

·
Premium Member
Joined
·
7,635 Posts
Cheers for that. I'll get it over the Litchfields before I look at doing any more high speed runs! :)
To be honest there isn't much they can do other than suggest a bigger more efficient intercooler to keep your IATs lower and a dyno log to check your tune.

Your standard ICs were never meant to handle a stage 4.25 at full WOT on a runway high speed run!

Also without any logs to check over they can only place an educated guess on what caused the flat spot. That said I'm 99.9% sure it was high IATs.
Be reassured though that as long as your car is running a safe, well mapped tune, teh ECU is doing exactly what is was meant do to keep your engine safe.
 

·
Registered
Joined
·
1,920 Posts
It sounds like you ran into one of the cobb safety trips - it will cut the throttle until you lift off to under 25% throttle for a set time @ 1-2 seconds, then it will reset - if you had the accessport connected it would have told you why it tripped - stft / knock / temps etc been awhile so there maybe a few more safety trips added
 
1 - 7 of 7 Posts
Top