GTR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi everyone, I have a problem with my R32 that is really rather annoying. Let me explain:


So a few days ago, I go to start my car and roll down my windows, and find that my power windows are not working. Both passenger and driver window controls do absolutely nothing.

Also, my Front Torque Gauge, Fuel Level Gauge, RPM gauge, Engine Pressure gauge, and coolant temp gauge are all not working. The gauges are OEM. The only gauge that is working is the speedometer, because it is a mechanical speedometer, not electrical. If I'm not mistaken?

But anyways, I have no idea where to begin in terms of finding the problem. Are the windows and gauges an interrelated problem? I have yet to change my Power Window 25 amp fuse under the hood, although the fuse appears fine, the metal strip in the middle has not melted.

Any help would be very appreciated,

thanks alot,
Nolan
 

·
Registered
Joined
·
78 Posts
Hmm... I had this kind of problem on my gts4. A new battery fixed it - even though the old one worked fine (well, provided the car was started at least once a week. which of course it was. usually)

Battery voltage & altenator.

And yes, replacing the battery fixed the power windows and the stero.
 

·
Registered
Joined
·
5,016 Posts
Probably down to a bad earth if all fuses are fine. Wiggle the batterypoles and earthpoints and check whether everything works again ;) If yes go ahead and clean them :D
 

·
Registered
Joined
·
22 Posts
hey did you ever find the issue? im having the exact same thing. if it was a ground can you post a pic of where it was located. ive had this issue 6 months now
 
1 - 5 of 5 Posts
Top