GTR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi,

Is anyone from this forum an active member or have access to gtroc.com?
I've tried to register and have failed, the reason I'm asking is because my car was shipped from Japan and it had a gtr club owner sticker on it. Now i'm trying to figure out exactly what parts my car had been installed as the engine has failed from lack of oil to the bottom end =(..

ANy help would be great, link to the car is
R33 GTR-Vspec - japanese car import, s15, r33, r32, r34, skyline, buy japanese car, car import perth, buy turbo car, s13, 180sx, v35, nissan
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
the list of the parts at the link are what is visible, so we're unsure about:

-turbos?
-engine internals?
-chipped/remapped ecu?
-type of suspension?
 

·
Registered
Joined
·
3,107 Posts
Green shocks would suggest TEIN suspension.

TE37 wheels, don't kerb them!

Looks like standard AFM's so suspect might still have original turbo's. What is it set to boost too? If over 1 Bar then likely turbo upgrade.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
cheers for that! I totally missed the green shocks.

the boost was set low 0.8bar and high 1 bar on the boost controller, which makes me think their stock...however they boost real late. either that or the it's very very noticeable when the second turbo kicks in, at 5k the revs sort of slow/quick pause before a big surge of power kicks in. car is very lumpy aswell so i suspect cams..

what do you think?
 

·
Registered
Joined
·
1,329 Posts
cheers for that! I totally missed the green shocks.

the boost was set low 0.8bar and high 1 bar on the boost controller, which makes me think their stock...however they boost real late. either that or the it's very very noticeable when the second turbo kicks in, at 5k the revs sort of slow/quick pause before a big surge of power kicks in. car is very lumpy aswell so i suspect cams..

what do you think?
i think both turbos spool together:thumbsup:
 

·
Registered
Joined
·
3,107 Posts
I think that if its running 0.8-1Bar its standard turbo's, the lumpiness could be cams, and/or an ECU mapped for something(s) that are no longer fitted........

Lot of guages and boost controller does not really make sense if you have standard turbos. Likewise fitting high lift(?), longer duration cams. Could be they have fitted N1's or similar. Pictures don't really show you what you need to know. Part number off turbo would be informative. Is it a standard ECU in footwell? No sign of a PFC or V-pro anywhere, so might be re-chipped OEM.
 
1 - 6 of 6 Posts
Top