GTR Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter #1
Hi guys,

I originally posted this in the general section which I think is the wrong section so I have reported here......

I was driving home today in the rain. Put my foot down and ABS, ESP, 4WD, skid warning lights came on, with message saying "ESP SYSTEM MALFUNCTION VISIT DEALER". I pulled over and turned the car off for a few minutes and turned back on but lights were still on. Then they all went off, so I set off again. Then cruising along at 70mph 1 hour into my journey they all came on again! So I basically limped home at 55mph for last half hour.

All I can think of is that the tyres are due for a change as the tread is very low.....could this combined with the very wet conditions cause these warning lights to come on?
I've got a sneaky feeling that it's gonna be something and nothing, because I ran the diagnostic test and it came back with 4zeros which means nothing's wrong.

I'm planning to ring Andy at AC Speedtech in Warrington tomorrow, but Has anyone else had this happen to them?

Any info/advise is much appreciated.
__________________
 

·
Registered
Joined
·
202 Posts
how bizarre this is exactly what i had today . switched off and on again and the lights went off. Last night at a junction though the car wouldn't accelerate at all as the traction control was stopping it moving . got it booked in at nobles for a service but wondering what this could be .
 

·
Registered
Joined
·
336 Posts
Discussion Starter #3
Wow!....ironic!

Well I had no problem at all with acceleration. In fact the car felt totally normal, accept obviously all the power was at the rear wheels.
 

·
Registered
Joined
·
202 Posts
Off phone to dealer. Car is getting recovered tomorrow as they think it's a wheel bearing and didn't want me to drive it the 70 miles to the garage . Will keep you posted on the outcome
 

·
Registered
Joined
·
336 Posts
Discussion Starter #7
Ok mate, I'll look forward to hearing if that was the problem!

I spoke to ACSpeedtech on the phone, and I told him about the fact that my tyres are very low n he said to get them changed first as that COULD cause the problem.
I've ordered the tyres so I'll post after they are fitted (could be a good few days as I'm going away soon)

Daryl
 

·
Registered
Joined
·
336 Posts
Discussion Starter #10
Excellent mate.....glad it was nothing major on the old wallet ;-)

I'm away with work for a few days, will get tyres fitted when I get back and report if it's cured my problem.
 

·
Registered
Joined
·
202 Posts
thankfully didn't cost me anything haha, thumbs up to a.f noble for that !.
I've heard tyres can cause it too hopefully that sorts it out for you mate !
 

·
Registered
Joined
·
336 Posts
Discussion Starter #12
Good news mate!

Yeah hopefully that's my cause....but I've heard a few causes for it....even wheel nuts slightly coming loose!!!

But I'll post up once I know what was causing mine ;-)
 

·
Registered
Joined
·
202 Posts
Well car is away back seems the sensor needs replaced rather than cleaned . Oh well hopefully have it back later this week lol damn
 

·
Registered
Joined
·
336 Posts
Discussion Starter #15
Well I got the tyres fitted yesterday.
Still all clear from the warning lights after 4 runs! Hopefully it stays like this and none of the warning lights appear again.
The front tyres were nearly legal to be fair and the rears had about 3mm tread left on em.
Fingers crossed I won't be updating on this thread!!!!
 

·
Registered
Joined
·
336 Posts
Discussion Starter #18
Well, guess what?
All lit up like a Christmas tree yesterday, and again this morning. So I rand Andy at Speedtech in Warrington, and he told me to bring it down. It's only round the corner from Blackpool so off I went (after getting my house roof fixed!!).

First time I've met Andy, but what a top bloke!....plugged it in, and had it on ramps, checked everything over for me (as I only got the car in November).
....final diagnosis is the same as you robgtr90....rear abs sensor. So a new one has been ordered, and will hopefully be fitted early next week.

I'll update once it's done.

Btw, whie I was with Andy we went through potential upgrades.......n it's my birthday soon!!! ;-)
 

·
Registered
Joined
·
202 Posts
Well, guess what?
All lit up like a Christmas tree yesterday, and again this morning. So I rand Andy at Speedtech in Warrington, and he told me to bring it down. It's only round the corner from Blackpool so off I went (after getting my house roof fixed!!).

First time I've met Andy, but what a top
bloke!....plugged it in, and had it on ramps, checked everything over for me (as I only got the car in November).
....final diagnosis is the same as you robgtr90....rear abs sensor. So a new one has been ordered, and will hopefully be fitted early next week.

I'll update once it's done.

Btw, whie I was with Andy we went through potential upgrades.......n it's my birthday soon!!! ;-)
nightmare mate ! At least it's getting sorted . What upgrades you thinking of ?
Just away to fit blow off valves tonight.
 

·
Registered
Joined
·
336 Posts
Discussion Starter #20
Yeah, it's like my roof....even though it was more expense, I'm greatful it wasn't worse......hopefully the abs sensor will be the same sort of attitude lol.

Upgrades, well at the mo my car only has a Ypipe and an "off the shelf" map with licences etc.
So I'll be looking along the lines of custom remap, injectors, Induction kit, maybe downpipes......but it's all talk at the mo.....need to have a more in depth chat with Andy, then I'll decide.

.....just want it running sweet first lol
 
1 - 20 of 31 Posts
Top