GTR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
895 Posts
Discussion Starter #1
right here goes.
basically ive set off very hard in first gear on the dragstip then in my attempt to change super fast missed second gear an put the car in neutral :eek: at the same time hit the throttle an revved it to the limit. anyway tootled back an parked it up then there was a tapping noise at the top end.like a lifter tap. also the oil light came on an warning light.
spoke to a bloke who was racing a westfield an he thought the engine sounded ok just a bit tappy.
so decided to limp the car home. only got about 100 yards outside the dragway and all the ignition lights came on and the car died....pulled the clutch back out an it came back to life only for it to die again after 15 more yards. then it would not turn over nevermind start. and theres no oil pressure showing on the gauge.
so before i sell my wife an buy an engine is there any parts that may of broke instead of all of the engine.
any ideas please im desperate after seeing you all smoke the opposition on sunday at elvington to get back on the road
thanx lee
 

·
Registered
Joined
·
3,636 Posts
It's possible that you blew off an intercooler hose The symptoms you describe sound very bad, but very similar to what I experienced and all it turned out to be was the hose.

Still scary though.
 

·
Registered
Joined
·
4,145 Posts
But he says he had a tapping noise and the oil warning light came on.

Would a blown off intercooler pipe do the above symptoms??
 

·
Registered
Joined
·
272 Posts
:( I would say to drain the oil in it , and hope no pieces of metal come out . it doesnt sound promising , you could have run a bearing , and possibly destroyed the whole engine , if it doesnt turn over then there is something stopping it , maybe a rod bent and jammed between crank and girdle or possibly through the block . what is your rev limiter set at ?
 

·
Registered
Joined
·
3,636 Posts
r33 v-spec said:
But he says he had a tapping noise and the oil warning light came on.

Would a blown off intercooler pipe do the above symptoms??
Actually you're probably right.

I only just noticed that the date he posted was back in August, see this thread for the diagnosis.
 

·
Registered
Joined
·
720 Posts
Think Brenham is right, there is a spring loaded valve inside the oil pump there to regulate pressure, its possible that the pump has picked up some debris (from whatever broke) causing the valve to stick open losing all the oil pressure. Thats probably why the oil light come on, and you've siezed and knackered most of the bearing's in the engine.
 
1 - 6 of 6 Posts
Top