GTR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,724 Posts
Discussion Starter · #1 ·
I was wondering what the sypmtoms were when the turbos let go.. Having a play tonight and the car almost like skipped and according to the person behind me the car started chucking bits out of the rear end ( could have been stones but they say not) anyway, the car boosts OK in 1st/ 2nd/ 3rd but when its hits about 5K revs in 4th &5th there seems to be no or very little acceleration , the car just seems very flat but it only feels like this in the 2 top gears.. it doesn't smoke at the moment ( Fingers crossed), The car is my daily drive and I dont want to use it if the tubbies have gone as it could make things worse...:(

:( :( :(
 
G

·
According to Abbey, if the turbos let go in a big way the shrapnel enters the engine and Im guessing if this happened you would know about it in no uncertain terms.

But I am no expert at all, if it was me though I'd get it looked at, and I would definately blag a lift to where these bits were alleged to be leaving your exhaust and take a look around (if you can)

Again according to Abbey the standard GTR turbos dont give much warning about impending doom either.

As I said Im no expert, just relaying a conversation I had with Abbey.

Good luck mate,
 

·
Registered
Joined
·
1,757 Posts
First thought that came

to mind was SHED...and this confrims my appreciations...

on further analysis we hope it is the knock sensor and where the car is under heavy load, it is knocking it back maybe sensing some det.

Fingers crossed for the gaylord.

NLW
 

·
Registered
Joined
·
1,193 Posts
Paul...

you may well have checked this but I had a similar prob with mine (before it died) and it was down to a split hose and a dodgy jubilee clip on another section. The split looked very minor but once removed it was knackered... just a thought.

Luke
 

·
Registered
Joined
·
1,724 Posts
Discussion Starter · #5 ·
split

Ta Luke... I couldn't check this last night but I will when I get home... I suppose I will have to check them all.. even the little ones...:D
 

·
Registered
Joined
·
3,047 Posts
PMJ

Hola,

Obviously lets hope its something trivial like Durzels but I was down at Garys about 3 months back and he had a R33, standard one, and it was all flat and no-go, turned out the exhaust wheel on one of the turbos had let go and shot the blades straight out the exhaust. It is more common I think for it all to shoot into your bores and fick everything up, however it could be just that the wheels have blown down the pipe if everything seems OK.

If you hit a brickwall, maybe worth calling god to see if the symptoms are the same as he went straight to the problem. Ive got his number if you dont have it. Worth a try if you dont find the prob instantly, I only mention it cos this car had the same prob.

Check the silly things first, hope OK:)
 

·
Registered
Joined
·
1,724 Posts
Discussion Starter · #7 ·
flat

Thanks Dirk... I have a plan, Maybe upgrade the turbo's, but only if its needed... not too sure what else can be checked by me so it may have to go to the garage and let the experts take a look..Sounds more like the ECU is detecting det some where.... Oh well I didn't want to take the kids to Florida next year....:D :(
 
G

·
Regarding the detonation, does the ECU restrict boost on the GTR as well as retarding the ignition? - Just wondered if yours is boosting up as it should? Could be a spilt hose, boost leak etc, does it make a hissing noise?

Sorry the questions are sort of rhetorical but I am curious as to what probs you are having. I hope you get them sorted mate.. let us know what the garage say anyway and good luck.:)
 

·
Registered
Joined
·
2,056 Posts
When the turbo went on my bike, I was on full boost. The boost went for a second, came back for a second, went again, came back and then went for good. After that, each time I tried to get boost out of it there was a howling whining noise which turned out to be high pitched vibration caused by the impeller fouling on the housing and orbiting round on the inside surface.

Of course, that was the symptoms of excessive bearing wear allowing the impeller to foul the housing. It didn't have ceramic blades to suddenly shatter or anything like that.

One thing was certain though - once it was gone it would not give boost in any gear at any revs. It wasn't rev or gear dependant.
 

·
Registered
Joined
·
3,047 Posts
Class A

I donno, it was a GTR not GTS, dont know the full ins and outs, just see it up on the ramp with its guts hanging out, you now know as much as I do about it:)

Bye....
 
1 - 10 of 10 Posts
Top