GTR Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
294 Posts
Discussion Starter #1
Hi all, I have an issue where my HICAS light comes on briefly if I am accelerating hard. During this fleeting moment the power steering drops out. Pretty hairy when in corners.

  • I've just replaced the speedo cable as that was suggested as the issue.
  • I've connected to HICAS ECU and steering wheel is reporting correct position relative to real life.
  • Battery has been freshly charged and reads approx 14.something volts when running.
  • Have cleaned up earth points on rear subframe as I recently epoxied that.
  • Speedo is stock and still in km/h.
  • ATTESSA pump does seem to prime frequently (every 10 seconds or so), unsure if that's related.
Any ideas? I'm missing out on track days and general car enjoyment at the moment as I haven't got the confidence in the car.

Not interested in removing HICAS at the moment and not convinced that would help anyway as I'm losing power assistance to the steering every time it drops.

Thanks in advance
 

·
Registered
Joined
·
18 Posts
I was having the exact same issue, resolved it by installing a Tomei Hicas lock kit as Im not too fond of the system, especially on the track.
 

·
Premium Member
Joined
·
294 Posts
Discussion Starter #5
I've also checked the power steering fluid level and whilst it needed topping up, this hasn't resolved the issue.

Any ideas?
 

·
Premium Member
Joined
·
294 Posts
Discussion Starter #6
For anyone that's interested, I disassembled the HICAS control unit to confirm that no screws had come loose inside (as Nissan Australia issued a service amendment to loctite these down). Nothing had come loose inside.
 

·
Registered
Joined
·
12 Posts
I was having the exact same issue, resolved it by installing a Tomei Hicas lock kit as Im not too fond of the system, especially on the track.
This is a band-aid and doesn't fix anything. You lose power steering when you install this. :ROFLMAO:
 
1 - 8 of 8 Posts
Top