GTR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
838 Posts
This is basically the same for an R33 or a Stagea; the only diiference to my knowledge is the KMH input wire on an R33 is Grey/Red and on the same plug as all the other wires.

The write up below is for a Stagea, so amend as above if you are doing an
R33.

Undo 4 corner screws under steering column binacle to remove top of binacle.

Lower steering column

Undo 2 screws above speedo display

Remove speedo shroud. You will need to disconnect plugs from switches which can be a pain, but they do come out.

Remove 4 screws holding the speedo in and then remove speedo.

Unplug the 3 plugs from the back. One goes to the rev counter side and won't be touched during this procedure.

Best to invest in some proper bullet connectors or solder the joints.

So here is the wiring bit:

Red wire from chip goes to battery terminal screw on speedo
Green wire from chip goes to earth screw on speedo

ECU output wire from chip goes to green/yellow wire on larger plug behind speedo. Cut the plug end of the wire and tape it off, then connect ecu output wire from the chip to loom end of the green/yellow wire.

On smaller plug behind speedo cut the black/white wire. Loom end goes to KMH input wire on chip and the plug end connects to the MPH output wire from the chip.

I bloody hate electrics!

Hope it makes sense! ;)
 

·
Registered
Joined
·
134 Posts
Was this a chip without a speed limiter cut?

Also use a cloth ontop of the steering column so that you dont scratch the clocks or the plastic when removing as it can be fiddly.
 

·
Registered
Joined
·
838 Posts
Discussion Starter #3
No, it removed the speed limiter, or at least increased it to 180mph!

Good tip with the cloth, it can be fiddly, like you say.
 

·
Skyline Section Manager
Joined
·
11,872 Posts
I've just removed one because it never reads 0. If I plug the laptop into the car, the speed never reads less than 4km/h, usually 6km/h. Because of this,nthe odometer rolls up whenever the ignition is on. Also, because the ECU never reads zero road speed, the AAC sometimes doesn't drop the idle to 950rpm

Also, the 4WD and HICAS work incorrectly in MPH

Apart from that, it's a great idea.:)

Sorry for the seemingly nevative post.
 

·
Registered
Joined
·
838 Posts
Discussion Starter #5
That sounds rubbish. There does seem to be mixed reports on these things and some may work better than others.
I got mine from JDM Garage if that's any help.

Or just stay with KMH!
 

·
Skyline Section Manager
Joined
·
11,872 Posts
I had one on my R33GTSt and that was really crap. It read 5mph on the speedo all the time.
I would think that there are some that don't do that. Electrically they are simple and I don't understand why there are sold like that.

I like KMH, I've driven like it for well over a year and don't have any problems.
 

·
Premium Member
Joined
·
8,083 Posts
i've not had a problem in the 5 wire chip that was in my old R33,ran spot on the whole time it was fitted,though i changed the clocks properly by sending them to RSP (even though they took forever to send them back!)
 

·
Registered
Joined
·
134 Posts
The cheap ones dont do the job as they should, well you do get what you pay for! Or it could have been a bad earth causing the problem?
 
1 - 8 of 8 Posts
Top