GTR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi guys,

Just purchased my GTR recently, and after driving for a couple of hours suffers from a loss of boost. after shutting off the engine for a while (say 15 minutes) all boost is fully restored. The brass ristrictor has been removed by the previous owner, although there seems to be some kind of electronic boost restrictor? I'm getting 1 bar max approx. though when it loses boost, max will reach .7 bar roughly.

'95 R33 with mild mods and what looks to be original ECU

Any ideas?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Serviced it yesterday, nows not a good time to be spending money on diagnosis's.

Will have to put up with it for the time being if it happens again. I'll post the outcome if and when I get a solution...
 

·
Registered
Joined
·
916 Posts
Funny that, I've just fitted aftermarket downpipes and a De-Cat to my '32 GTR. I now have no EGT sensor, and my boost has dropped from .9 bar to .7 ??

Regards
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Had it looked at, the mechanic suspects the boost control solenoid. Is it good to keep to factory or am I better off with an after market gem?

Still at the trial and error stages though, so I'm waiting patiently for answers ...
 

·
Registered
Joined
·
1,663 Posts
stealth said:
Do most folk find boost is down a bit in hot humid weather?
Yes of course, high inlet temps = less dense air which = less charge which = less boost. :)

Mine looses about 0.2bar in the summer when it’s hot.

On really cold days in the winter, the car goes fcuking mental, shame there is never any traction at that time of year though..

It appears that the best engine conditions = the worst driving conditions !
 

·
Registered
Joined
·
348 Posts
i posted a thread this week and this is exactly what mine was doing, total loss of power and when i restarted everything was fine. but it hasnt done that for a while i think my problem is a hole in my center box so going for a stainless cat back this week to see if my power ups. also i was thinking of replacing the old solenoid.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
I recently came across this thread, "strange intermittent boost problem".

Definately sounding like a solenoid related issue
 

·
Registered
Joined
·
251 Posts
I recently came across this thread, "strange intermittent boost problem".

Definately sounding like a solenoid related issue
What solenoid????

I have just bought my R33 GTR so I am finding all the idiosyncracies out at the moment...

0.5-0.6 Bar of boost at the moment - waiting for a cold day to see if it is just ambient temp... If not though, what is this solenoid you speak of?

J
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
I'm no car expert, so please feel free to correct my following attempt...
Near the radiator overflow resivoir and behind the jumper connector box on the driver side of the engine, there is a smallish cylinder shape device with a couple of hoses attached and power feed (if you've the factory). Just like your automatic garden sprinkler's it opens up a valve and that's as much as I know about it. Yours may still have the brass restrictor in one of the tubes which limits the boost to comply with certain regulations
 
1 - 11 of 11 Posts
Top