GTR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
where is the blue hose going??? and how to check if i have the stock turbos?? what is the difference with the valve cover red?? and mine is black?? how to reconnect my apexi's booster control as it was disconnected from the ecu....,my VAFC is the only one working....thanx...here's the pix...and what others do i need to do to speed up my gtr in a quartermile??
 

·
Registered
Joined
·
1,844 Posts
lotsa questions...

Red engine cover is for GTR34
that blue vacume line seems to be going to your tubbies actuator/s see if their is a T and the other end of it should be to boost control selnoid.

Selnoid should also get intake vacume,, I have no idea and I think most people cant answer if you have stock tubbies if you dont look and get us some numbers
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
i can't see any T.... where shoudl it be located?, and i observe also the little vacuum hose with a little red filter, near the actuator, is condemned using a little screw on it,,,so it could be.....and the wires also of the controller inside the dashboard is disconnected from the ecu.....what is could be>?? helpd thanx
 

·
Registered
Joined
·
1,844 Posts
"vacuum hose with a little red filter"
That should be going under your intake plenum

Other side near the power steering check the blue vacume house if it splits and goes into both tubbies. check where all the lines lead. from the looks of things your boost controller should work as soon as you plug it back in the Ecu.
 
1 - 4 of 4 Posts
Top