GTR Forum banner

1 - 20 of 59 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hi I'm heartbroken. Hoping someone can help!

R35 GTR 2017 model it's done 13,000 miles. Was running a COBB ECU and TCM map. The car mostly sits in an enclosed garage and barely gets driven.

Today, I change the map on the TCM before starting the car from cold. (I'll explain why in a moment). Once the map was changed, started it up, all seemed good. Backed it out of the garage and left it idling for 5 mins on a slightly tilted driveway (front was up). Went to back out on the road and it needed a bit of a pedal push, more so than usual. Put it into drive and got lots of revs, lots of slip. Then error message about T/M overheating. Pulled the car up, left it to rest.

About 10 mins later, started it up, it came up with T/M malfunction. Read the code it said P2715. It clears the code but comes back as soon as the vehicle is started again. It allows me to select reverse but won't drive in reverse all. Will only allow gear 2 in drive but high revs and lots of slip.

I'm about to do a transmission oil and filter, would this cure it? Help!

(The reason for changing the map is COBB support asked me to put the factory TCM map back on as my launch control was giving me loads of gearbox slip and no power to the road so they wanted to see if switching back would help).
 

·
Registered
Joined
·
26,149 Posts
Sounds like the transmission was slipping and having issues regardless of the map

i highly doubt an oil change will fix it

get it to Kaiser if you in the south
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
Sounds like the transmission was slipping and having issues regardless of the map

i highly doubt an oil change will fix it

get it to Kaiser if you in the south
Thanks. Happy to strip the sump off and have a look at those solenoids there but not sure which ones I'm looking for!
 

·
Registered
Joined
·
26,149 Posts
Is your 35 in warranty ? If you start messing about with it , you may find it an issue with Nissan
 

·
Registered
Joined
·
33 Posts
Discussion Starter #11
That's a good question. What's the warranty on these? Google said 3 yrs. I'm the 2nd owner and it's a 2017.
 

·
Ooo Matron !
Joined
·
2,230 Posts
That's a good question. What's the warranty on these? Google said 3 yrs. I'm the 2nd owner and it's a 2017.
Nissan will not be entertaining any warranty claim if you have modified anything, let along the ECU and TCM.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #13
Ok, so back to my original question before we got sidetracked with the warranty question.

Anyone got an idea of where this solenoid is located please?
 

·
Registered
Joined
·
18 Posts
Hope you get your car sorted mate I’m based in Cambridge too when your car is fixed give me a message we’ll go for a drive
 

·
Registered
Joined
·
33 Posts
Discussion Starter #16
Hope you get your car sorted mate I’m based in Cambridge too when your car is fixed give me a message we’ll go for a drive
Hey! Thanks and will do. I think we saw eachother a while back (god, must have been 2 yrs back)? You were driving into a retail park as I was driving out? Was that you?
 

·
Premium Member
Joined
·
673 Posts
Have you tried reloading the Cobb TCM map? And/or that you loaded the right one? Worth retrying that for the sake a few mins to rule it out.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #20
Have you tried reloading the Cobb TCM map? And/or that you loaded the right one? Worth retrying that for the sake a few mins to rule it out.
Thanks for the very good idea. I should have mentioned since that I've uninstalled the Cobb map entirely, then reset the fault code, then tried it again but still the same issue. Even tried reflashing the Cobb map that was on there before I flashed the one this morning. Unfortunately still the same behaviour and error code :(
 
1 - 20 of 59 Posts
Top