GTR Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hiya

Recently got my new toy (R33 GTST from 'Bill Sky') and love it except for...

Once warmed up, if I come up to a junction, the idle is all over the shop and it often stalls.
I've done a search and as it DOES have a BOV (HKS SSQV) I assume its this, except no-one mentioned if these cause stalling ALL the time or just when warm.

Could it be something else?
AFAIK - standard ECU, decat, the BOV and ITG induction.

Even when I park and put her into neutral, the idle is really up and down and generally parking etc. is a nightmare! :mad:

Thanks for any advice you can offer for a newbie.
The car IS booked into Hyeline (Cardiff) for a full check over but thats not until next Friday (29th) and I'd like to get her sorted before then if poss.

Cheers, Chris ~:)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
Damn - that was a quick reply! :clap:
Will check the battery, ta. Shocked this could cause that prob but would certainly be an easy fix...

Here's hoping, ta! Chris ~:)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
Thanks. The battery connections do seem good so it must be the BOV or somein else.

Hopefully the guys at Hyeline will get it sorted next Friday.
I guess till then I've got a car thats a headache to drive. :(

Cheers anywho...

Chris ~:)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
Thought it time for an update mostly incase someone else finds this thread with a similar problem...

Car went in to Hyeline in Cardiff to check car over and also sort this annoying stalling prob.
Car (more or less) checks out as being a really nice car. Few minor probs, which is to be expected, like coupla gasets leaking, scored discs, etc... All easily sorted.

Re: the stalling - they recomended an HKS EIDS (Idle Controller) which will "eliminate the problem". They had the car for a week and assured me all was well and that it'd been thoroughly tested and can't be stalled. On the way from cardiff back to Bristol... yep, stalling. :eek:

It seems to get significantly worse as the car warms up and now the car gets almost undriveable when in town as it will stall at every junction, roundabout and moving along in a slow queue is a no-no.

Car is going BACK to Hyeline on Saturday to be adjusted and hopefully they'll get it right this time. Shame cos the guys there are really friendly, seem really knowledgeable and apart from this problem I would highly recommend them. We'll see how it goes on Saturday.

Will update when its done and hopefully will have some good news...

Chris ~:)
 

·
Registered
Joined
·
44 Posts
Discussion Starter #8
I've checked the connections and they are sound.
You mean a faulty / dying battery? Without meaning to sound TOO newbie... is there a test I can do or just bite the bullet and get a new battery.

BTW - stalls less when AC is on but I guess its just the revs being higher with AC on?

Cheers for advice, Chris ~:)
 

·
Registered
Joined
·
61 Posts
mines stalled cos the connections were shit.. so just tightend them up... but no harm in checking ur battery with a volt meter
 

·
Registered
Joined
·
134 Posts
I had the same problem on my first GTS-T.

I had the HKS BOV aswell tried adjusting the BOV to no avail. I was recommended the HKS Idle controller aswell bought it and ended up not fitting it. The best option would be to take out the idle control valve and give it a thourgh clean with carb cleaner as this made a huge difference on my car. It would still stall occasionally but not as frequent as before and made the car alot nicer to drive. This is what Marc @ The Garage did to my car, when I was a Skyline newbie.

Hope that helps.

:thumbsup:
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
Cheers guys...

Battery voltage seems fine and charging fine so doesn't seem to be that.

That link is tops - nice easy instructions that even a muppet like me can follow. :cool:

Soon as I get some cleaner and the weather cheers up, I'm on it!
Thanks! :bowdown1:

Chris ~:)
 

·
Registered
Joined
·
3,384 Posts
Cheers guys...

Battery voltage seems fine and charging fine so doesn't seem to be that.

That link is tops - nice easy instructions that even a muppet like me can follow. :cool:

Soon as I get some cleaner and the weather cheers up, I'm on it!
Thanks! :bowdown1:

Chris ~:)
Some WD40 does nicely.:smokin:

Andy.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #14
SORTED! :D

- AAC Valve cleaned & rebuilt - a bit carbon'd but even when cleaned - still stalled.
- Throttle valve - was clean anyway but rebuilt - still stalled.
- BOV - Stripped, cleaned, spring tightened - much less chav with whoosh only on full throttle but STILL stalling.

Steven at Hyeline did all this for me and I think he was tearing his hair out with my car a bit.
The EIDS was performing exactly as it should, all the AFM readings were spot on...
He then basically stripped & rebuilt all the pipework in the engine bay. SUCCESS!
Looks like either one of the pipes was faulty and/or poorly put together.
A lot of the pretty blue pipes have gone so the engine looks a bit crapper but I'll get that sorted. The car itself runs like a dream now.
I thought it was good before but a bit over-sensitive and tempremental.
NOW its just a dream to drive - prefect throttle response, idles perfectly and with the BOV spring tightened its SO much less chav when trying to be subtle down quiet roads.

A big thanks to everyone and their advice which I did follow.
And of course espesh to Steve @ Hyeline, Cardiff who stuck with it and got it sorted.

Chris ~:)
 
1 - 14 of 14 Posts
Top