GTR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
Had my MOT done yesterday and the shop who did it was very impressed how good the car state was considering is 7 years old but he found oil on the driver side engine mount and he said he can't tell where it comes from. We looked everywhere and couldn't see any leaks, never had to add oil between services and the car never used oil and never found oil drips under the car.
I can see through the wheel arch the engine mount covered in oil.

Any ideas where that oil leak could come from? I will lift the car up next week and remove the wheel to look better but on the ramp we couldn't find the source.

The car was recently serviced and inspected by Autotorque and they didn't mention any issues.


Any ideas where should I look? I'm off to a long road trip(4000miles) in 2 weeks.

Thanks
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #2 ·
I was told possible turbo oil lines leaking, a known issue apparently.

Problem is the engine has to come out and new braided lines to go in (£1000job) so I hope is something else cause I can't have another canceled holiday after all the covid19 ones!!
 

·
Registered
Joined
·
13 Posts
I was told possible turbo oil lines leaking, a known issue apparently.

Problem is the engine has to come out and new braided lines to go in (£1000job) so I hope is something else cause I can't have another canceled holiday after all the covid19 ones!!
HI, Take out the sensors on the intercooler pipe at the top and put a scope camera to the turbines and see it there is any oil there, this has happen to mine and had them rebuilt only 5 months ago. you will see the oil to the bottom of the picture and it has leak then through the pipe and drip down like you have said.





Hood Netbook Gadget Communication Device Display device
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #5 ·
HI, Take out the sensors on the intercooler pipe at the top and put a scope camera to the turbines and see it there is any oil there, this has happen to mine and had them rebuilt only 5 months ago. you will see the oil to the bottom of the picture and it has leak then through the pipe and drip down like you have said.
I had a look today and there is no oil in the turbos or anywhere around the turbo area.

I've seen oil on the engine mount and drive shaft but it looks like it comes from the right side, from the rubber hose that the return line connects to.

I think is leaking from the return oil hose, from where the metal pipe connects to the rubber hose.

I will have a look tomorrow properly if it's just a simple hose clamp that failed(fingers crossed) but it is booked in for next week anyway in case I can't locate the leak.
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #7 ·
I recorded the footage on the statoscope camera and checked again, I traced the pipe to the turbo and it's dry, only place where there is oil is on the hose clamp and down from there on the rubber hose itself and engine mount/ drive shaft.
Tomorrow I take the wheel off and check the clamp, hope that's the culprit.

Here is the video:
 
1 - 10 of 10 Posts
Top