GTR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,267 Posts
Discussion Starter #1
Hi all

Was driving my skyline today, no one els in the car newr the power FC, it was working when i left my house, i glanced down and the FC's screen was blank. the car was still running fine though. i pulled over and turned the car off and turned it on again, still not working though. the screen only does a little fliker thats it, the backlight dosnt even come on. Does anyone know what the problem could be?


Thanks

JAmes.
 

·
Registered
Joined
·
8,541 Posts
Check the connections to the commander. Either that or the LCD screens goosed. The fact that the car runs OK seems to indicate the ECU itself is working.

TT
 

·
Registered
Joined
·
2,267 Posts
Discussion Starter #3
will have a look at the connections, if the computer stopped working completely, would the car be running very badley or not at all?

James.
 

·
Registered
Joined
·
2,267 Posts
Discussion Starter #5
thanks for that mate.
 

·
Hawaii-5-0
Joined
·
1,817 Posts
If the unit itself had died your car wouldn't be running.

Most likely the din connector where the wire plugs into the ECU, it's not very stable and has no lock so is prone to wiggling free. The symptoms you describe sounds like an imperfect connection.
 

·
Registered
Joined
·
2,267 Posts
Discussion Starter #7
awsome, atleast i know the machines still working then. I will go and have a look at the connection from the ECU.

Thanks

James.
 
1 - 7 of 7 Posts
Top