GTR Forum banner

1 - 12 of 12 Posts

·
R35 Section manager
Joined
·
11,052 Posts
Discussion Starter #1
Hi Chaps,


On starting my GTR 33 1995,the Hicas light is staying on. If I switch the car off and re start it it will go out.
It has started to come back on whilst driving now tho.

I have checked the power steering and brake fluid-Both fine.


I have done a search,but cant find the same problems.


Please help.:mad: :confused:
 

·
Registered
Joined
·
1,398 Posts
Possibly the steering postion sensor on th steering column. Common fault on R32's, so I assume maybe same on R33's.

Miguel
 

·
R35 Section manager
Joined
·
11,052 Posts
Discussion Starter #3
Possibly the steering postion sensor on th steering column. Common fault on R32's, so I assume maybe same on R33's.

Miguel


Where abouts would that be found mate??
 

·
Registered
Joined
·
715 Posts
take it to a nissan dealer and get the consult plugged in to see what the fault is. The 32 and 33 hicas systems are different in there components and operation.
 

·
Registered
Joined
·
553 Posts
You checked the fluid levels of the reservoire in the boot (RHS)

There was a debate earlier as to if this was for the HICAS or the ATTESSA (spelling) but it's worth a try

Sev
 

·
R35 Section manager
Joined
·
11,052 Posts
Discussion Starter #8
Checked the boot fluid and thats fine also.
 

·
Registered
Joined
·
3,029 Posts
Maybe this is a sign!

Get a HICAS replacement bar and shave 50kg off the wieght (or so i've heard!)

Just a thought

Sev
Heard wrong. The Aussies and a few others on other sites and threads weighed the difference and it was only about 5kg difference with a lightweight bar added in :mad: So no point doing to save weight unless you remove the whole system and even then it's not a great amount of weight saved (about 8kg).

Some 240sx owners also removed the "whole" HICAS system and weighed them with the following results...

HICAS solenoid - 6.4lbs (~3kg)

rear HICAS rack - 10.8lbs (~5kg)

rear HICAS distribution block - 5.2lbs (~2kg)
 

·
R35 Section manager
Joined
·
11,052 Posts
Discussion Starter #11
I think the problem is due to the power steering fluid running low.Possible leak??

Think I may need to give Abbey a call,unless someone can think of an idea???
 

·
R35 Section manager
Joined
·
11,052 Posts
Discussion Starter #12
Took it to Abbey today,it turned out to be a steering sensor £187 inc labour.
Hopefully thats the end of the problem now.
 
1 - 12 of 12 Posts
Top