GTR Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
897 Posts
Discussion Starter · #1 ·
When I start my R32 up the ABS and 4WD light comes on, the car had been sitting around for 4 months while I was away on business.

Now what is happening is that for atleast 30 mins the light stays on. Then if I was to switch the engine off and back on it goes back to 4WD and the lights remain off.

Any ideas what it can be?
 

·
Registered
Joined
·
160 Posts
Does either of these lights come on when you are moving? Chances are that when the ABS system is going through a self test it's picking up a faulty wheel sensor. With the car being sat chances are some moisture may have fouind it's way into one of the wheel speed sensor plugs, check these first. Other than that do you know someone with the Nissan Consult diagnostics?
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #3 ·
Does not happen when the car is moving.. its when I start the car up first time the lights dont go out.. and remain for something like 30 mins or so of driving. SOmetimes after that if I stop the car and start up its back to normal I get full 4wd.
 

·
Registered
Joined
·
160 Posts
Sounds like the system is picking up a fault during the self test. Get someone with Nissan Consult to check it, you will save a load of hassle and time by doing this. Good luck mate.
 

·
Registered
Joined
·
396 Posts
They both have the same fuse by your right knee so they are on the same circuit.
Sounds like a bad Earth to me.
 

·
Registered
Joined
·
897 Posts
Discussion Starter · #7 ·
Thanks Andy does seem strange though why it clears after a long drive... Is there anyway to reset the 4WD Ecu?
 
1 - 7 of 7 Posts
Top