GTR Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter · #1 ·
Always done this since I bought it. When you switch the car off instead of just stopping it slows down and slowly dies like its just stalled. Any advice would be great thanks.
 

·
Registered
Joined
·
9,751 Posts
Air flow meter the most likely cause. I had this when I bought my car, got charged £450 by a specialist to get them replaced with second hand ones ... We live and learn.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #3 ·
Hey mate, thanks for the reply. Funny you should say this, I just tried unplugging one of my maf with the engine running and it didn't affect it. I couldn't get to the other one without burning myself!. I think you may be right. Ill try swapping them for a known working set and get back to you. May be a good excuse to upgrade them :p
 

·
Registered
Joined
·
9,751 Posts
If you upgrade them you will need a remap so more expense, but there is a trick to repair them before you consign it to the rubbish bin :)
 

·
Registered
Joined
·
325 Posts
Engine won't run without spark either.
OP hasn't replied as to fitment of a turbo timer.
They're notorious for slow discharge once the IGN is switched off, even with the cool down time set at zero.
Dials will drop to zero at the key "OFF", but engine will struggle on and slowly stall.
Pretty easy to disconnect the patch harness and try it without T.T.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #8 ·
Thanks for the replys.

I have replaced the mafs with a good known working set, no luck continues to over run.

I dont have a turbo timer installed and the injectors are new RC 750cc installed by ron at RK tuning 900miles ago.

Could it have anything to do with the timing?

I have a hks v pro gold ecu, I was told that theise ecus make the engine over run on purpose, anyone got one who can shed some light on this? Thanks:)
 

·
Registered
Joined
·
591 Posts
Sounds like it's pulling power from the fuel pump but not the ignition - could be on purpose to de-pressurise the fuel system but that's unlikely!
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #10 ·
just a solution in case anyone else comes across this forum with the same problem. it turned out to be my F-Con Pro Ecu doing it. i swapped it out of a standard GTR ecu i had lying around and the problem stopped.:)
 
1 - 10 of 10 Posts
Top