GTR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1
What could be the cause of my car running really rich? I changed the spark plugs for new ones (the old ones were very black) and it ran ok on idle for a few minutes but then started missfiring again.

The coils all seem ok no cracks or anything.

I unplugged the LAMDA sensors and it didnt seem to make any difference.

The car did have a SAFC fitted before i bought it - could removing this have screwed something up?

Butuz
 

·
Registered
Joined
·
8,543 Posts
Maybe knackered AFM's telling ECU to supply more fuel?????

TT
 

·
Registered
Joined
·
501 Posts
Discussion Starter #4
Hmm cheers for that.

So can you refurbish AFM's or is it just a case of replacing them?

Butuz
 

·
Registered
Joined
·
1,335 Posts
you can clean AFM's easily by spraying a bit of brake cleaner on the sensor, make sure you let it dry off properly before refitting though.

If you have an aftermarket ecu then id take it to a tuner for a remap (after removing the SAFC it might have changed things ?) and they will find whats causing it very quickly if not...
 

·
Registered
Joined
·
501 Posts
Discussion Starter #6
Ok thanks for that I will try cleaning the AFM's.

I do not think I have an aftermarket ECU but I don't know for sure.

How can I check?

Cheers

Butuz
 

·
Registered
Joined
·
1,335 Posts
they usually have a sticker on the outside of the ECU case if they have been played with in japan, its behind the kick panel in passenger footwell...
 

·
Registered
Joined
·
501 Posts
Discussion Starter #9
Well its only on Idle that i am trying it at the mo - i have not taken it out on the road.

Butuz
 
1 - 9 of 9 Posts
Top