GTR Forum banner

1 - 20 of 26 Posts

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #1

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #5
Yes, these are perfect fitment as they were developed using the original parts.
 

·
Registered
Joined
·
1,123 Posts
You didn't respond in PM so i'll post here instead then.

I bought these in october or something like that in 2011.
Earlier this week i tried fitting them and the promised "perfekt fitment" just wasn't there.
If i was told that they didn't fit as they should i would never have bought them.

Anyway here's some pictures of it...





ImageShack® - Online Photo and Video Hosting
 

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #7
Hi,

Sorry, I think next time please try to contact us before posting on here as we offered them to be perfect fitment, then we will always honour that.

Please can you send them back to us and we shall check what the problem is. Perhaps you received a bad mold (although we have QC checks, it is possible that sometimes 1 or 2 isnt checked properly which is why we offer guarantee). If a replacement is required, then we will send you a new one set.

To all customers: please in future check fitment as soon as you receive the parts to eliminate any return/warranty problems when they go out of the standard policy periods. And we would not like to upset any customers if they find a fitment issue when its outside the returns policy period.. we will let this occasion be an exception as this is the first issue we have had with this particular product so we are sure it's just a bad mold from factory (although they are designed on go on standard rear lights, but nevertheless, we will check them first)

Thanks
Albert
 

·
Registered
Joined
·
1,123 Posts
Earlier i have sent you an email regarding other stuff but no response.
I sent a PM to you regarding this issue if it was this past tuesday maybe and no response.
I thought i'd give you a week but since you've been online several times and i haven't got any answer i made a post instead.

Send me a Pm with details of what you want me to do.

Hi,

Sorry, I think next time please try to contact us before posting on here as we offered them to be perfect fitment, then we will always honour that.

Please can you send them back to us and we shall check what the problem is. Perhaps you received a bad mold (although we have QC checks, it is possible that sometimes 1 or 2 isnt checked properly which is why we offer guarantee). If a replacement is required, then we will send you a new one set.

To all customers: please in future check fitment as soon as you receive the parts to eliminate any return/warranty problems when they go out of the standard policy periods. And we would not like to upset any customers if they find a fitment issue when its outside the returns policy period.. we will let this occasion be an exception as this is the first issue we have had with this particular product so we are sure it's just a bad mold from factory (although they are designed on go on standard rear lights, but nevertheless, we will check them first)

Thanks
Albert
 

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #9
Sorry, although we try to answer all emails and pm's sometimes they can get overlooked. We do have a sales telephone line 01908 379118 that you can call to speak to our office team immediately for issues like these.

Anyway please send to our address located on our website contact page here:

Contact Us
 

·
Registered
Joined
·
1,123 Posts
I went and checked more closly today and the problem is that the standard tail covers have much smaller and round fitting points.
Where yours are rectangular and much bigger. Altough the height of them seemed correct it's just the size of them that's the problem.

I do have aftermarket taillights but the standard covers fit so then these should fit aswell...
 

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #11
Ah i see.

Sorry for the trouble. Can you please send them back to us and we will have a closer look and try get this solved as soon as possible for you.

Thanks
Albert
 

·
Registered
Joined
·
1,123 Posts
Ah i see.

Sorry for the trouble. Can you please send them back to us and we will have a closer look and try get this solved as soon as possible for you.

Thanks
Albert
Sure thing! I'll get them posted during this week.
Here you can see the difference


 

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #13
Ah i see the problem now.

I will have a word with my guys at the office on Monday and confirm how this is supposed to be fitted. It could well be fitted using adhesive. But either way, please return and we will check it against an R33 tail light we have in stock.

Thanks
Albert
 

·
Registered
Joined
·
1,123 Posts
I was told that i was shipped back to me on the 6th of march.
Nothing has arrived though so i don't know the fitment yet.
 

·
Vendor
Joined
·
2,975 Posts
Discussion Starter #20
Yes. We needed to make a small modification on them. Now test fitted and ready.

Brains... you're was shipped this week as we had to modify a new set for you since my boys dropped your original set when packing them... sorry for the delay
 
1 - 20 of 26 Posts
Top