GTR Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter #1
Hi all just wondering i have above car (brembo brakes)and the brake pedal is very hard there is servo action because if pump till pedal hard then start engine with foot on pedal the pedal does move slightly. But the brakes don't feel very good alot of pressure needed but not a lot of stopping power. is this normal.
 

·
Premium Member
Joined
·
3,835 Posts
No - doesn't sound right - check for vacuum leaks on the pipes from the manifold to the brake servo and the clutch servo - clutch servo sometimes splits on the end of the can.
 

·
Registered
Joined
·
1,726 Posts
As above - what pads are you running? Some higher temp pads require considerable heat before giving a better feel. Lower temps or coldness on mine for example gives a kind of wooden feel until I have got some heat into the pads and discs at which point they become much better and responsive.
 

·
Registered
Joined
·
139 Posts
Discussion Starter #5
Hi thanks for ideas will check all hoses. Pads look normal but will remove on weekend to see if non standard are fitted. what is the round plastic black canister in between vacum pick up pipe to servo pipe sits o/s/f under bonnet what is and what does. Thank you.
 

·
Registered
Joined
·
32 Posts
Did you manage to get to the bottom of this? Think I've got the same issue, some servo assistance but when pressing pedal hard, it takes a lot of force for not a lot of stopping power, just changed to ebc discs and ds2500 pads
 

·
Registered
Joined
·
32 Posts
been thinking the same freakazoid...whats the best way to track a leak down as some of the vac pipes disappear beneath the mani and dont wanna strip all that out if its something else!
 
1 - 15 of 15 Posts
Top