GTR Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hi guys , I've got an r34 gtr that has been running fine . On My way home the Car seemed to want to stop ( no power no revs ) putting foot down didn't help but then it sprung into life and was fine all night . Trouble is it happened again tonight so is causing me some concern . Turbos are all pulling a treat and there are no other symptoms of problems . It feels from a lamens point of veiw as if the fuel has been cut off . Any thoughts would be appreciated . Thanks in advance
 

·
Registered
Joined
·
444 Posts
I would check:

Air flow meters
coils
Vaccum pipes
intercooler pipes
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #6 ·
Sounds like it could be pump to. How long does it play up for? Just a second or to? Any warning lights come on? Does it actually cut out or not!
It does feel like it cuts out but on the 2 occasions it happens
Momentum keeps it going and it spring back into life. No warning lights come on and both times I was on a bit of a hill. Only does it for about 3 seconds.
 

·
Skyline Section Manager
Joined
·
11,878 Posts
You need to monitor a few things before you start swapping things about.
Have you got a fuel pressure gauge?
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #9 ·
You need to monitor a few things before you start swapping things about.
Have you got a fuel pressure gauge?
No , the car is still as I bought it , I will take it up to rb motor sports when I come back off holidays and see what's going on .
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #11 ·
Afm mate , where you based ?
On the wirral mate . I posted another thread yesterday mentioning that also I had noticed the car seemed to be holding back a bit and only boosting up to .74 and no more , ( usually goes up to .98 ish ) I disconnected the afm this morning and gave all the connections a good blow out and reconnected it . Car felt immediately better and boosted as normal . Fuel gauge seemed to be dropping quicker than normal too . Will see if that improves it .
 

·
Vendor
Joined
·
3,505 Posts
On the wirral mate . I posted another thread yesterday mentioning that also I had noticed the car seemed to be holding back a bit and only boosting up to .74 and no more , ( usually goes up to .98 ish ) I disconnected the afm this morning and gave all the connections a good blow out and reconnected it . Car felt immediately better and boosted as normal . Fuel gauge seemed to be dropping quicker than normal too . Will see if that improves it .


I've had the same before a few times and I was afms, see how they go
 
1 - 13 of 13 Posts
Top