GTR Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello everyone, i just received my gtr on the weekend. Awesome machine I may say!!! Has lots of power and is in awesome shape. The only down side about the car is everything is new to me so im not sure whats up with it. First gear pulls hard right up to 8000 second to six only goes to 4000 ish and start boggin out , its like its telling me to shift to next gear. Looses power and all. I just ordered new plugs and 6 coil packs to start. What else could i be looking for? Car is completely stock in my eyes besides an exhaust and boost controller. I havnt touched the boost controller bc im not sure what im up against. Any ideas from other owners?
P.S Im new to this site and wanted to say hello to everyone out there:wavey:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Another thought would it be the high end turbo? Bc first gear the low end turbo works and than from 2th to 6th low end turbo works to 4000ish rpm and the higher end turbo doesnt take over. Would that make any sense....
 

·
Registered
Joined
·
38 Posts
Im also pretty new to owning a R34 GT-R but if i can tell you one thing, i had similar problems with power loses out of no where and engine only revving up to 3000rpm and then not going further and so on. Check the Air flow meters. Was the problem for me. As i know now, its quite often the problem with these cars.

The RB26DETT is not turbocharging sequentially. Both turbos spool up at anytime boost is coming up.

Hope this helps you, otherwise someone else may be able to help here ^_^
 
1 - 3 of 3 Posts
Top