GTR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,896 Posts
Discussion Starter #1
Just got home from driving the car and she was smoking (got very worried). Poped bonnet to find rad cap sat there off the radiator, so the smoke was the water evaporating. Fild the rad back up and have replaced the cap. The engine temp didn't go high nor did the oil tempreture.

Is there anything I should do now? have I killed somthing?

I put some water in teh rad the other day so might not have put the cap on properly.
 

·
Registered
Joined
·
1,896 Posts
Discussion Starter #3
R32 Combat said:
Have you removed the bleed screw by the fuel injector rail and bled the system?
Nope, but sounds like a job for tomorrow

Any instructions etc would be great :)
 

·
Skyline Section Manager
Joined
·
11,872 Posts
When cold, remove the screw and fill with the rad with water until the water comes out the hole. Screw the screw back in. Thats the water system bled.

 

·
Registered
Joined
·
1,896 Posts
Discussion Starter #5
Magic, thanks for that, picture really helps. Do you know where the thermostat is while we are talking about the cooling system.

TBH I'm suppries how cool the car was running since took a fair bit of water and it was all over the engine bay :(
 

·
Registered
Joined
·
4,936 Posts
R32 Combat said:
When cold, remove the screw and fill with the rad with water until the water comes out the hole. Screw the screw back in. Thats the water system bled.

Good man.

Thing's like this is why i am still here.:D :D :D :D :D


Mick
 
1 - 7 of 7 Posts
Top