GTR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys,

Got a 33 GTST, and I'm having a boost issue under heavy load around 5.5k feels like its spluttering/missing etc. Its happened after installing a FMIC? Now, I've checked all the pipes and doesn't seem to be any leaks, I also swapped out old plugs with some new 0.8s and the car came with Splitfires so not sure how old they are. I cleaned the MAF today, along with taking the coils out and giving them a good inspection and clean and they look fine. I also did a compression test whilst these were all out and results were fine. What more can I try before I start replacing parts?

I'm not sure if its linked, however on startup car starts fine the shoots up to close to 2k revs and within seconds dies down and idles normal. But, starting the car from warm it can cough and then do the opposite and idle low, I replaced temp sensor and that it on that end but not sure if any of its linked lol.

Cheers everyone! :)
James
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
If its only after fitting the FMIC and youve checked it for leaks, all I can say is it sounds v much like an ignition fault. Maybe the extra cold air is blowing the spark out on one of the cylinders. Both coils and amp are equally as common to go.
Thanks for your reply bud. Would it be best to test coils one by one? And what do you mean by AMP? I suspected a spark blowout as it makes the most sense. I’ve tried two different sets of plugs 1.1 and 0.8 so can rule them out. So can only assume coils.
 

·
Premium Member
Joined
·
3,001 Posts
the amp on an rb26 is mounted at the back of the engine. I think the rb25 is similar. The only thing is, with coils; you cant really test them under boost. The only thing you can do is swap them one by one.
I assume your talking plug gaps. I use NGK BKR8EIX plugs with standard gaps (dont know what the gap is) but if your running a 6 heat range or possibly 7, this may give you an issue too.
Its most likely a coil breaking down id say.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
the amp on an rb26 is mounted at the back of the engine. I think the rb25 is similar. The only thing is, with coils; you cant really test them under boost. The only thing you can do is swap them one by one.
I assume your talking plug gaps. I use NGK BKR8EIX plugs with standard gaps (dont know what the gap is) but if your running a 6 heat range or possibly 7, this may give you an issue too.
Its most likely a coil breaking down id say.
Good point reg testing! As Car runs fine otherwise so may be a cause of grabbing a new set of coils and going from there. And recommendations? I’m looking at Superforma as font particular have the money to go for 35 Coils so I think superformas will suffice! :) and in reg to plugs in running BKR8EIX and standard gap I believe is 1.1 so could be be worth going back to factory gap. Thanks mate
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
I’ve never had a problem with the NGKs running 1.5bar and I’ve still got stock coils.
35 coils are meant to be great.
Awesome! I’d love a set of stock coils tbh, but all used ones online. A couple of forums mentioned superformas just being a reconditioned version of the stock Nissan coils. So I’ll give them a go! Appreciate your help bud
 

·
Registered
Joined
·
230 Posts
Hitachi IGC0029 are new stock coils for the R32/R33 RB26 with ignitor. In the US they are 50 USD each, pretty cheap if you're sticking with OEM coilpacks. Only issue is they don't come with the coil boots.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Hitachi IGC0029 are new stock coils for the R32/R33 RB26 with ignitor. In the US they are 50 USD each, pretty cheap if you're sticking with OEM coilpacks. Only issue is they don't come with the coil boots.
Nice one! I'm going to try a set of Superforma from JDM Garage and see how we get on. Fingers crossed it's a coil related problem so I can just be done with it lol!

Cheers mate :)
 
1 - 9 of 9 Posts
Top