GTR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, this is my first post so be gentle. Had my 2017 a while now and just been gone to stage one. Wheels were balanced and threw a weight on near side front. To it to my local place for rebalance and ever since ride is very stiff and the switch set to comfort makes no difference. Any ideas on what is causing this. Many Thanks
 

·
Premium Member
Joined
·
349 Posts
The wheel balance shouldn't cause that problem, did you need to change tyres at the same time and that's when they noticed the wheel weight was missing?? Only thing I can think of is if new tyres they might have stiffer sidewalls or set at very high pressure, or your front shock isn't working right? Does seem strange - did you get any other work done at the time e.g. car hit pothole, that's how it lost the wheel weight, rim checked for damage and spring/struts too? Might the garage have "messed" with something??
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The wheel balance shouldn't cause that problem, did you need to change tyres at the same time and that's when they noticed the wheel weight was missing?? Only thing I can think of is if new tyres they might have stiffer sidewalls or set at very high pressure, or your front shock isn't working right? Does seem strange - did you get any other work done at the time e.g. car hit pothole, that's how it lost the wheel weight, rim checked for damage and spring/struts too? Might the garage have "messed" with something??
No new tyres just same Michelin's. Checked the pressures and they were all 3 to 4 pound over. Strange as Litchfield did service etc, maybe they had a newby do the tyres. Did ask them and they said they always set at 30 but after run this morning they were all showing 35psi. Now deflated them to 30 (after cooled down) but can't take it out yet. Fingers crossed this does the trick.
Will post results.

Thanks very much for responding to my post(y)
 

·
Premium Member
Joined
·
349 Posts
No worries. 35psi when warm is probably 32 cold so that's probably about right, but its personal preference. I've got Cup2s and have tried various pressures, using advice on this forum. For me, 31/32 cold is pretty much the sweet spot. 29 felt too soft (I set it at this per Nissan - but that's with runflat tyres and they have stiffer sidewalls - and 34 just felt too hard. Might be you had been running lower pressure, say 29, and the 32/33 cold was too crashy. Definitely worth a play around with pressure, certainly seems to make a difference from what I've found.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Just got a dry window and took it out to try new pressures. No real difference, you could be right about the pressures before the service/alignment/remap. Litchfield assure me their software would not affect the suspension. Feels like its in race setting all the time and it corners better than ever but the bumps are bone rattlers. Can't find any threads on probs with setting switch . Warranty is about to expire so might be worth trying main dealer and hope they don't notice the stage one upgrade.
 
1 - 5 of 5 Posts
Top