GTR Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter · #1 ·
After putting new wheels, suspension units, rack ends etc on I thought that a vibration I had at around 80mph would go away. Also had weird vibrations at other speeds.
(it is a R33 GTR but with a R34 engine and gearbox so the front half of the prop is from a 34)
But it hasn't so today took the prop down to have it balanced and checked.
They have rang and said it's ready, and it was quite alot out.
So I'll drop a note if it cures it, just incase anyone has similar issues.
If it doesn't I'll bang my head agaisnt a brick wall.

Cheers
 

·
Registered
Joined
·
4,586 Posts
How well ballanced are the new wheels?

I had some new tyres put on a while ago, and one of the wheel weights fell off and it felt like the car was going to come apart at motorway speeds.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #3 ·
Wow

Got the prop back on last night and omg, it has completely transformed how the cars feels. It as smooth as now, wish I'd had it balanced before now.
 

·
Registered
Joined
·
8,804 Posts
wow, never knew that propshaft balancing was a needed thing. I'll add that to the to-do list.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #5 ·
It was only needed because the front half of the prop came off a R34, this was bolted to the rear half of my existing r33 prop. This is to allow the R34 G box into the R33!

If there's no vibrations etc a balance probably isn't needed.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top