GTR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1 (Edited)
Hey all

I've used walbro fuel pumps for a few years now, I've had the same one in my Nissan for 6 years and in my rx7 for 4 years.

But having recently purchased one 8 montbs ago for my gtr which failed within 3 months and then having it replaced and now the new one failing I can't help but feel they have massively lost their QC.

Has anyone else had any issues with the latest iterations and what other would you recommend I don't really want to replace it with another walbro

Thanks in advance
 

·
Registered
Joined
·
2,304 Posts
Have you got the pump in the bottom of the tank? Walbro fuel pumps are not lift pumps so if there positioned in the same place as the standard pump they won't last long
 

·
Registered
Joined
·
163 Posts
Discussion Starter #6
Have you got the pump in the bottom of the tank? Walbro fuel pumps are not lift pumps so if there positioned in the same place as the standard pump they won't last long
Nope it was relocated, not sure why I've had issues :-/

Has anyone else had issues with the latest walbro ones or am I just incredibly unlucky?
 

·
Registered
Joined
·
268 Posts
Nope it was relocated, not sure why I've had issues :-/

Has anyone else had issues with the latest walbro ones or am I just incredibly unlucky?
Are you sure you got a pump made in USA, not just a chinese fake item? Many of them on ebay are chinese, not genuine. Maybe that's the reason. It's like chinese turbo, it works but not long :)
Anyway, 255 lph version doesn't hold pressure really good under boost, so, I don't recommend using it if your boost is over 1.2 bar.
 
1 - 10 of 10 Posts
Top