GTR Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,883 Posts
Discussion Starter · #1 ·
Hi

My indicators have stopped working.... i was looking for the relay, but couldnt find it.
Also checked the workshop manual, didnt find it there either.

Any got a clue to where it is??

Thanks

Asim...
 

·
Registered
Joined
·
1,341 Posts
sorry to be vague but im sure its under the dash between the pedels and the steering wheel, dont think its by the fuse box or under the bonnet. also try just behind the ecu, will have a listen tomorow but im sure my first guess will be closest.
 

·
Registered
Joined
·
1,883 Posts
Discussion Starter · #7 ·
sorry to be vague but im sure its under the dash between the pedels and the steering wheel, dont think its by the fuse box or under the bonnet. also try just behind the ecu, will have a listen tomorow but im sure my first guess will be closest.
Cheers for that.... i would be really interested in a pic of it.
Or if you could tell me a more presice location....

Thanks a mill bud :)

Asim....
 

·
Registered
Joined
·
92 Posts
Anyone know where this relay is? Taken off the steering wheel cowling, ignition cowling and the brown di-pole relay that is supposed to be it is nowhere to be seen! Indicators don't work at all, neither do the hazards so I can't follow any noises. I was told it was somewhere close to where the ignition key goes in but removing that cover there isn't anything relay shaped there of the appropriate colour. There are only the blue single pole relays which are all labelled on the photos posted previously as being for other things.

Someone must know.....
 

·
Registered
Joined
·
92 Posts
Found it. Been lead on a wild goose chase... the indicator relay is a black box with a white label on it under the steering column. The relay I have been sent is totally wrong which explains why I couldn't find another brown relay under there!

Have taken some pics so others can find theirs!



Image tag doesn't seem to work in preview so here's a link to the 3 photos which show where it is and with close ups of it:

hobnob : photos : skyline- powered by SmugMug
 

·
Registered
Joined
·
295 Posts
I know this is an old thread -

but top marks for the pics of relay-

My hazards work but no indicators -
Has happened before and auto electrician changed relay

I was wondering, now that I know where it is to change it,
Where did you get a new relay from????


regards
Carl
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top